Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Laang

GPU Problem

Recommended Posts

Posted · Original PosterOP

Hey, I got a old r9 280x from a friend and he said that it wasn't working.

That it just blackscreened his PC, after installing it in my PC I booted up windows normaly and was able to install drivers with no issues, but the moment I started up a GPU intensive task ( In this case I opened up World of Warcraft) the PC just restarted, no BSOD or anything just a insta shutdown and booted up again.

After testing I've noticed that it can handle lower GPU loads (Ran heaven benchmark with diffrent settings, specificly lowering the resolution made the crashes stop fully, it ran on ultra with 1280x1024 resolution with no issues, then I tried running it at 720p it made it half way and again crashed), I also cleaned the GPU from any dust, the PSU is a 650W unit that is old 2 weeks so it shouldn't be a problem.

Any help would be much appreciated, and if there is a faulty component on the GPU how does one test to see what part is wrong. Thanks in advance and sorry for bad english

 

My PC:

Intel core I5-2400

XFX R9 280x DD Black Edition (Currently using old Zotac GTX 750 TI 1GB)

Generic 2x2 and 1x4 GB ram

Corsair CV650

128GB WD SSD

250GB Generic HDD

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×