Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
TinkrTonkr

BRAND NEW RX 570 with mining bios? NOW THIS IS WEIRD?!?!

Recommended Posts

Posted · Original PosterOP

Hi guys!

 

I got Gygabyte RX 580 card from here https://www.pccomponentes.pt/gigabyte-radeon-rx-570-gaming-8g-mi-8gb-gddr5

 

Arrived today, got a new PSU, set it up, it was not detected, error code 43 on device manager

 

So I google and came upon a software ATIKMDAG patcher that found limits on all rates on the GPU, which means it's modded, usually for mining!!

 

I patched it with the software, 2 seconds, was immediatley detected and runs fine

 

But how can it be?! What the hell...

 

Also in the board (MSI B350M Bazooka) it is "Unknown driver" "Unknown Device" on Internal GOP Configuration, if I trun windows 10 whql support it does not post, 3 beeps (i used that before with 1050Ti because enabling the setting gives you a different boot screen on msi board)

 

What the hell?

 

Anyone knows if it's possible the card has wrong bios even though it's brand new? (Was sealed and visually looks totally new, even "smells new")

 

EDIT: GPU-Z PIC https://imgur.com/FIFia18

Link to post
Share on other sites

GV-RX570GAMING-8GD-MI

 

The "MI" in the SKU would make me think it stands for "mining" but I can't seem to find anything that supports this theory. I would check with Gigabyte directly to see what the deal is. Is that site kind of like the Newegg of your country or is it more like the Aliexpress?

Link to post
Share on other sites
Posted · Original PosterOP
7 minutes ago, TempestCatto said:

GV-RX570GAMING-8GD-MI

 

The "MI" in the SKU would make me think it stands for "mining" but I can't seem to find anything that supports this theory. I would check with Gigabyte directly to see what the deal is. Is that site kind of like the Newegg of your country or is it more like the Aliexpress?

I confirmed, it's a mining card... But on the site it does not say anything, any warning, lol 😕 It's more like Newegg

 

I contacted Gygabyte for a gaming bios, maybe they are nice enough to send it for me to flash, or then I'll try returning it

Link to post
Share on other sites
12 minutes ago, TinkrTonkr said:

I confirmed, it's a mining card... But on the site it does not say anything, any warning, lol 😕 It's more like Newegg

 

I contacted Gygabyte for a gaming bios, maybe they are nice enough to send it for me to flash, or then I'll try returning it

You can download the BIOS from TechPowerUp

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Od1sseas said:

You can download the BIOS from TechPowerUp

They don't have a BIOS specific to this card, only 4Gb version, if anyone has a Gaming Version, with 8Gb, and Micron memory and can provide the bios would be awesome!

 

To be more specific: GIGABYTE RX 570 8GB GAMING, with Micron Memory, is what I'm looking for

Link to post
Share on other sites
8 hours ago, TinkrTonkr said:

They don't have a BIOS specific to this card, only 4Gb version, if anyone has a Gaming Version, with 8Gb, and Micron memory and can provide the bios would be awesome!

 

To be more specific: GIGABYTE RX 570 8GB GAMING, with Micron Memory, is what I'm looking for

Not this one? 
https://www.techpowerup.com/vgabios/206147/gigabyte-rx5708gb-8192-180505


| Intel i7-3770@4.2Ghz | Asus Z77-V | Zotac 980 Ti Amp! Omega | DDR3 1800mhz 4GB x4 | 300GB Intel DC S3500 SSD | 512GB Plextor M5 Pro | 2x 1TB WD Blue HDD |
 | Enermax NAXN82+ 650W 80Plus Bronze | Fiio E07K | Grado SR80i | Cooler Master XB HAF EVO | Logitech G27 | Logitech G600 | CM Storm Quickfire TK | DualShock 4 |

Link to post
Share on other sites
27 minutes ago, TinkrTonkr said:

Yeah hadn't seen that, but already tried, ID mismatch, not risking it

If your current BIOS is mining BIOS from another card then you'll always get mismatch.


| Intel i7-3770@4.2Ghz | Asus Z77-V | Zotac 980 Ti Amp! Omega | DDR3 1800mhz 4GB x4 | 300GB Intel DC S3500 SSD | 512GB Plextor M5 Pro | 2x 1TB WD Blue HDD |
 | Enermax NAXN82+ 650W 80Plus Bronze | Fiio E07K | Grado SR80i | Cooler Master XB HAF EVO | Logitech G27 | Logitech G600 | CM Storm Quickfire TK | DualShock 4 |

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, xAcid9 said:

If your current BIOS is mining BIOS from another card then you'll always get mismatch.

If I force install, will it work?

Link to post
Share on other sites
Just now, TinkrTonkr said:

If I force install, will it work?

Most probably yes, make sure you backup your current BIOS just in case. 


| Intel i7-3770@4.2Ghz | Asus Z77-V | Zotac 980 Ti Amp! Omega | DDR3 1800mhz 4GB x4 | 300GB Intel DC S3500 SSD | 512GB Plextor M5 Pro | 2x 1TB WD Blue HDD |
 | Enermax NAXN82+ 650W 80Plus Bronze | Fiio E07K | Grado SR80i | Cooler Master XB HAF EVO | Logitech G27 | Logitech G600 | CM Storm Quickfire TK | DualShock 4 |

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×