Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
alanp1995

AMD Radeon Settings Driver Version Bug

Recommended Posts

Posted · Original PosterOP

So I am currently running version 19.1.1 of AMD Radeon Settings. My graphics card is an MSI R9 290. If you take a look at the screenshot image below, my "New Recommended" driver version is the same driver version I have installed, that surely is a bug? No matter how many times I reinstall the driver it is recommending I install the same version I have. I have no yet tried to update to 19.2.2, would that be the best option to do?

The reason why I would be scared to update is because 19.2.1 would not work at all, my computer would constantly crash, giving off a buzzing sound, and then once restarted it says "Default Radeon Wattman settings have been restored due to an unexpected system failure". I have tried so many fixes for this and nothing has helped.

Any help or suggested plans of action in relation to Radeon Settings suggesting I install the same version I already have, or taking a chance on upgrading to 19.2.2, is greatly appreciated.

 

OPP6HHJ.png

Link to post
Share on other sites

I'm running 19.2.2 for my CF VEGA64's and Radeon VII setups, I have no issue with it, custom fan curve set in Wattman is sticking and consistently starts up whenever I power up my rig.....something the previous drivers failed at......sometimes. Played Metro Exodus and RE2 without issue, even completed the former without a hitch......


Rig 1: Intel i7 3960X | Asus R4E | 16GB Corsair Dom Plat 2133mhz | 2x Gigabyte RX VEGA 64 Gaming OC (CrossFire) | Oppo HA-1 + KRK Rokit5 G3 | Caselabs M8 | Seasonic X-1250 | Leopold FC660C + Logitech G502 |Acer XR341CK 21:9 Freesync | 64bit Win10 Pro

Rig 2: Intel i7 4770K | ASRock Z87 Extreme6 | 16GB RipJawsX 2133mhz | PowerColor Radeon VII 16GB HBM | Fostex HP-A4 -> Oppo HA-1 + Rokit5 G3 | Tt View 31 | Enermax 1500 MAX Revo | KBT Race II MX Blue + Armaggeddon SRO-05 Havoc III | Samsung C49HG90DME 49" 32:9 | 64bit Win10 Pro

Rig 3:  Intel i7 2600K | Asus  | 16GB RipJawsX 1600mhz | Leadtek GTX1080 Hurricane OC | Gustard X12 + H10 + Virtue One + Bose 201 Series III | | Fractal | Corsair HX1050 | Logitech G613 + G603 Wireless  | Panasonic 65" 4K TV | 64bit Win10 Home

 

 

 

 

Link to post
Share on other sites
Posted · Original PosterOP
2 hours ago, GamerDude said:

I'm running 19.2.2 for my CF VEGA64's and Radeon VII setups, I have no issue with it, custom fan curve set in Wattman is sticking and consistently starts up whenever I power up my rig.....something the previous drivers failed at......sometimes. Played Metro Exodus and RE2 without issue, even completed the former without a hitch......

I can update and say that 19.2.2 no longer has the version bug. Although the Wattman crash error has happened 2 times in the past 3 hours. Is there any way of preventing the wattman crash happening? I do not have any overclock applied, everything in Wattman is set to default.

Link to post
Share on other sites
On 2/24/2019 at 7:20 AM, alanp1995 said:

I can update and say that 19.2.2 no longer has the version bug. Although the Wattman crash error has happened 2 times in the past 3 hours. Is there any way of preventing the wattman crash happening? I do not have any overclock applied, everything in Wattman is set to default.

You Are not alone i hade the same issu whit driver crashing when gaming/streaming  driver 19.2.2 

Link to post
Share on other sites
4 minutes ago, Kill_me_allready said:

You Are not alone i hade the same issu whit driver crashing when gaming/streaming  driver 19.2.2 

Ah, I don't stream, so I've not had issue with 19.2.2......


Rig 1: Intel i7 3960X | Asus R4E | 16GB Corsair Dom Plat 2133mhz | 2x Gigabyte RX VEGA 64 Gaming OC (CrossFire) | Oppo HA-1 + KRK Rokit5 G3 | Caselabs M8 | Seasonic X-1250 | Leopold FC660C + Logitech G502 |Acer XR341CK 21:9 Freesync | 64bit Win10 Pro

Rig 2: Intel i7 4770K | ASRock Z87 Extreme6 | 16GB RipJawsX 2133mhz | PowerColor Radeon VII 16GB HBM | Fostex HP-A4 -> Oppo HA-1 + Rokit5 G3 | Tt View 31 | Enermax 1500 MAX Revo | KBT Race II MX Blue + Armaggeddon SRO-05 Havoc III | Samsung C49HG90DME 49" 32:9 | 64bit Win10 Pro

Rig 3:  Intel i7 2600K | Asus  | 16GB RipJawsX 1600mhz | Leadtek GTX1080 Hurricane OC | Gustard X12 + H10 + Virtue One + Bose 201 Series III | | Fractal | Corsair HX1050 | Logitech G613 + G603 Wireless  | Panasonic 65" 4K TV | 64bit Win10 Home

 

 

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×