Jump to content

Black ops 3 frame drop

SnipingBow

I got a R9 390 and a i5-4460, and my frames get down to like 30 when there is an explosion or a fire fight.

 

Is there any way to fix this? I put my settings on medium but it did not seem to fix it.

 

Also the GPU temps is only at 60. I goes to 80 when playing witcher 3.

Link to comment
Share on other sites

Link to post
Share on other sites

This is normal for Black Ops 3 on PC, and do not expect it to be fixed.

 

I get horrendous frame drops all the time.

| Intel i7 5820K @ 4.8GHz | G.Skill Ripjaws 4X4GB | X99 PRO | HoF 980 | Asus MX299Q | Sennheiser HD600 |

Link to comment
Share on other sites

Link to post
Share on other sites

I got a R9 390 and a i5-4460, and my frames get down to like 30 when there is an explosion or a fire fight.

 

Is there any way to fix this? I put my settings on medium but it did not seem to fix it.

 

Also the GPU temps is only at 60. I goes to 80 when playing witcher 3.

Try reinstalling the AMD drivers.

 

 

The GPU goes to 80 degrees due to Witcher 3 being more demanding.

|CPU: Intel 5960X|MOBO:Rampage V Extreme|GPU:EVGA 980Ti SC 2 - Way SLI|RAM:G-Skill 32GB|CASE:900D|PSU:CorsairAX1200i|DISPLAY :Dell U2412M X3|SSD Intel 750 400GB, 2X Samsung 850 Pro|

Peripherals : | MOUSE : Logitech G602 | KEYBOARD: K70 RGB (Cherry MX Brown) | NAS: Synology DS1515+  - WD RED 3TB X 5|ROUTER: AC68U

Sound : | HEADPHONES: Sennheiser HD800 SPEAKERS: B&W CM9 (Front floorstanding) ,  B&W CM Center 2 (Centre) | AV RECEIVER : Denon 3806 | MY X99 BUILD LOG!

 

Link to comment
Share on other sites

Link to post
Share on other sites

This is normal for Black Ops 3 on PC, and do not expect it to be fixed.

 

I get horrendous frame drops all the time.

Did you do anything that helped you out?

 

Because I can't play at all

Link to comment
Share on other sites

Link to post
Share on other sites

Go through all your settings and optimize them better. With a 970 and 1440p and run High and easily stay above 60 even with the drops. The drop still happen though and are still npticeably annoying. I turn off stuff like MSAA and make shadows as low as possible. It's all about tweaking Ti reduce what impacts you specific setup the most.

Link to comment
Share on other sites

Link to post
Share on other sites

Go through all your settings and optimize them better. With a 970 and 1440p and run High and easily stay above 60 even with the drops. The drop still happen though and are still npticeably annoying. I turn off stuff like MSAA and make shadows as low as possible. It's all about tweaking Ti reduce what impacts you specific setup the most.

I unchecked the sync every frame. It works well, idk if its the right thing to do tho.

Link to comment
Share on other sites

Link to post
Share on other sites

its a shitty optimized peasant port

go play a different game

RIG #14670k @4.4 / 1.25v vcore. @ 4.5 / 1.3v vcore/ 1.95v vccin. MSI GAMING 4G GTX 970 @1540/3700 1.275v BIOS MOD. 16GB Kingston HyperX Savage RAM 2400mhz. MSI GAMING 5 Z97 MOBOFractal Design Define S. Dark Rock Pro 3. 850 EVO 250GB Seasonic M12II 620w
RIG #2: 4790k @ 4.6 / 1.25v vcore. EVGA SC ACX 2.0 980 SLI16GB Corsair Vengeance Pro 2400mhz. Asus MAXIMUS VII Hero Z97. Fractal Design Define R5. NH D15. 850 EVO 250GB AX 860
Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×