Jump to content

Blackscreen when power on

bry.yyyy
 Share

Go to solution Solved by bry.yyyy,

dammit,can you grab any other graphics card to verify that the problem is the GPU?

no i guess i will take this card to my local store and grab my warranty

btw thanks for help

hi guys i got problem here

so i recently plug the VGA Cable to my GPU (HD 5570) And got a blackscreen

but when i use onboard graphics no blackscreen all working

can i get solution on my GPU ?

Current Build + Setup

AMD Ryzen 5 5600X | GIGABYTE B550 Aorus Pro v2 | CORSAIR Dominator Platinum 16gb 3600Mhz | MSI RTX 3060 GAMING X OC 12 GB | NZXT H510 Elite | 1TBx2 Seagate Barracuda 7200RPM | ADATA XPG GAMMIX S7 512GB M.2-2280 NVME | Corsair CS750M 80+ Gold Modular PSU | NZXT Kraken X62 | Harman Kardon Soundstick 4 | ASUS TUF VG249Q

Link to comment
Share on other sites

Link to post
Share on other sites

connect a diffrent cable and check what you get,it might have died.

still same

Current Build + Setup

AMD Ryzen 5 5600X | GIGABYTE B550 Aorus Pro v2 | CORSAIR Dominator Platinum 16gb 3600Mhz | MSI RTX 3060 GAMING X OC 12 GB | NZXT H510 Elite | 1TBx2 Seagate Barracuda 7200RPM | ADATA XPG GAMMIX S7 512GB M.2-2280 NVME | Corsair CS750M 80+ Gold Modular PSU | NZXT Kraken X62 | Harman Kardon Soundstick 4 | ASUS TUF VG249Q

Link to comment
Share on other sites

Link to post
Share on other sites

still same

if it has power connectors,make sure they are connected and that the card is connected to the PCI slot correctly.

Link to comment
Share on other sites

Link to post
Share on other sites

if it has power connectors,make sure they are connected and that the card is connected to the PCI slot correctly.

no the card doesn't have Power connector

it already connected to the slot correctly

still no work

Current Build + Setup

AMD Ryzen 5 5600X | GIGABYTE B550 Aorus Pro v2 | CORSAIR Dominator Platinum 16gb 3600Mhz | MSI RTX 3060 GAMING X OC 12 GB | NZXT H510 Elite | 1TBx2 Seagate Barracuda 7200RPM | ADATA XPG GAMMIX S7 512GB M.2-2280 NVME | Corsair CS750M 80+ Gold Modular PSU | NZXT Kraken X62 | Harman Kardon Soundstick 4 | ASUS TUF VG249Q

Link to comment
Share on other sites

Link to post
Share on other sites

no the card doesn't have Power connector

it already connected to the slot correctly

still no work

do you have more pci slots on your mother board? move it around to a diffrent slot and try again

Link to comment
Share on other sites

Link to post
Share on other sites

do you have more pci slots on your mother board? move it around to a diffrent slot and try again

no i don't have just 1 PCI-E 3.0 Slot x16

Current Build + Setup

AMD Ryzen 5 5600X | GIGABYTE B550 Aorus Pro v2 | CORSAIR Dominator Platinum 16gb 3600Mhz | MSI RTX 3060 GAMING X OC 12 GB | NZXT H510 Elite | 1TBx2 Seagate Barracuda 7200RPM | ADATA XPG GAMMIX S7 512GB M.2-2280 NVME | Corsair CS750M 80+ Gold Modular PSU | NZXT Kraken X62 | Harman Kardon Soundstick 4 | ASUS TUF VG249Q

Link to comment
Share on other sites

Link to post
Share on other sites

no i don't have just 1 PCI-E 3.0 Slot x16

dammit,can you grab any other graphics card to verify that the problem is the GPU?

Link to comment
Share on other sites

Link to post
Share on other sites

dammit,can you grab any other graphics card to verify that the problem is the GPU?

no i guess i will take this card to my local store and grab my warranty

btw thanks for help

Current Build + Setup

AMD Ryzen 5 5600X | GIGABYTE B550 Aorus Pro v2 | CORSAIR Dominator Platinum 16gb 3600Mhz | MSI RTX 3060 GAMING X OC 12 GB | NZXT H510 Elite | 1TBx2 Seagate Barracuda 7200RPM | ADATA XPG GAMMIX S7 512GB M.2-2280 NVME | Corsair CS750M 80+ Gold Modular PSU | NZXT Kraken X62 | Harman Kardon Soundstick 4 | ASUS TUF VG249Q

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×