Jump to content

New LGA 2011 V3

Nikola Lukic
 Share

Hi all, i had a bit of trouble installing the corsair H100 on the new asus x99-S motherboard, the screws dont line up properly therefor making it impossible to run the system, now i was wandering since i couldnt find anything regarding, if anyone had the same problem and if its fixable, also if there isnt a fix i would like to know which watercooling is compatible with the board.

Thx

Link to comment
Share on other sites

Link to post
Share on other sites

should fit , at least its the same as the old 2011 socket .

took my H110 to S2011 v3 from X79.

No Problems whatsoever 

Main Rig : i7 5960X - 16GB DDR4 LPX 2400mhz - Asus Rampage V - 980GTX Ti - AX1200i - 650D - H110 - 1TB 840 EVO SSD - 30 inch HP 1600p IPS + 2xHP 20 inch 1600x1200 PLP setup! - Oculus DK2 - Logitech G502 - Corsair K70 RGB - Fanatec GT3 Wheel

i7 3930K - 16GB DDR3 2133mhz - Asus Rampage IV - 2 x 680GTX - AX850 - 550D - H100i - 256GB 830 Pro SSD - 2713HM 1440p IPS - G5 -

i5 3570K - MSI SLI Z87 motherboard - 4GB Corsair 1600mhz - Adaptec 31205 - Dell Perc 5/i - Intel Quad PT1000 Gigabit Network Card - Loads of 4TB RED's - +-70tb total storrage - HX850watts - Ri-Vier 24bay 4 U case

Link to comment
Share on other sites

Link to post
Share on other sites

well sorry to say it this way but you will have to use a bit of twisting force... 

 

even Corsairs the ram guy says this : 

We have looked into this a little closer, we tried different MB based on LGA2011 and I have to say that a lot of them will not align perfectly. You will need to apply a small amount of force on to the 4th hole to catch the stand off. Other than this small issue, the coldplate will still make a full contact on the CPU.
 
 

Main Rig : i7 5960X - 16GB DDR4 LPX 2400mhz - Asus Rampage V - 980GTX Ti - AX1200i - 650D - H110 - 1TB 840 EVO SSD - 30 inch HP 1600p IPS + 2xHP 20 inch 1600x1200 PLP setup! - Oculus DK2 - Logitech G502 - Corsair K70 RGB - Fanatec GT3 Wheel

i7 3930K - 16GB DDR3 2133mhz - Asus Rampage IV - 2 x 680GTX - AX850 - 550D - H100i - 256GB 830 Pro SSD - 2713HM 1440p IPS - G5 -

i5 3570K - MSI SLI Z87 motherboard - 4GB Corsair 1600mhz - Adaptec 31205 - Dell Perc 5/i - Intel Quad PT1000 Gigabit Network Card - Loads of 4TB RED's - +-70tb total storrage - HX850watts - Ri-Vier 24bay 4 U case

Link to comment
Share on other sites

Link to post
Share on other sites

I tried every angle and rotation with no luck also i do not want to put pressure on a new cpu, im going to buy a new cooler, which should i get from these, cotsair h100i or the corsair h105, and are these compatible?

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×