Jump to content

MSI secure boot and stuff

So all I'm trying to do is open Valorant, but when I do I get a popoup saying I need Vanguard TPM 2.0 and the game crashes. Apparently I need to enable something called secure boot. Sure. So I open BIOS, find secure boot and click enable. I am then told I need to use platform key (PK) to enable it. I find the setting for that but it wont let me set a platform key. My mobo is Z690 Pro A DDR4. OS is Win 11

Link to comment
Share on other sites

Link to post
Share on other sites

That's how I got Secure Boot :

1 - Make sure you unplug all SATA and USB drives, the M.2 drive has to be the only drive installed.
2 - Go into the bios, under the boot tab there is an option for CSM, make sure it is disabled.
3 - Click on secure boot option below and make sure it is set to other OS, Not windows UEFI.
4 - Click on key management and clear secure boot keys.
5 - Insert a USB memory stick with a UEFI bootable ISO of Windows 10 on it.
6 - Press F10 to save, exit and reboot.
7 - Windows will now start installing to your NVME drive as it has its own NVME driver built in.
8 - When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that Windows boot manager now lists your NVME drive.
9 - Click on secure boot again but now set it to Windows UEFI mode.
10 - Click on key management and install default secure boot keys
11 - Press F10 to save and exit and windows will finish the install.

Link to comment
Share on other sites

Link to post
Share on other sites

I was also struggling with this. No way I'm going through all this effort just to play a game. 

Moving on to something that's less of a hassle

Link to comment
Share on other sites

Link to post
Share on other sites

15 hours ago, leclod said:

That's how I got Secure Boot :

1 - Make sure you unplug all SATA and USB drives, the M.2 drive has to be the only drive installed.
2 - Go into the bios, under the boot tab there is an option for CSM, make sure it is disabled.
3 - Click on secure boot option below and make sure it is set to other OS, Not windows UEFI.
4 - Click on key management and clear secure boot keys.
5 - Insert a USB memory stick with a UEFI bootable ISO of Windows 10 on it.
6 - Press F10 to save, exit and reboot.
7 - Windows will now start installing to your NVME drive as it has its own NVME driver built in.
8 - When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that Windows boot manager now lists your NVME drive.
9 - Click on secure boot again but now set it to Windows UEFI mode.
10 - Click on key management and install default secure boot keys
11 - Press F10 to save and exit and windows will finish the install.

Thanks so much! Is there any way to do that without reinstalling windows?

Link to comment
Share on other sites

Link to post
Share on other sites

I don't know, but probably,

There must be many posts on that subject

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×