Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

AIO help

 Share

Hey guys, my Galahad Lian Li AIO has been bothering me lately, I can feel the water circulation but my pc always hits 86c+ within 30 - 45min of use. And always hits 86c when idle after a while. I've tried to search it up and I can't fix the problem, and I've only had it for maybe 6 months. Are there any fixes? Or do I need to buy a new AIO. Thanks.

Link to comment
Share on other sites

Link to post
Share on other sites

what are the full specs of the pc, and the rad/fan configuration? have you tried remounting/re-pasting it?

Link to comment
Share on other sites

Link to post
Share on other sites

AIO's don't last very long. I wouldn't recommend it (if you are not absolutely need it out of space reasons).

A Noctua NH-D15 outperforms nearly every AIO in temps and noise.

Link to comment
Share on other sites

Link to post
Share on other sites

3 hours ago, nathan902 said:

Hey guys, my Galahad Lian Li AIO has been bothering me lately, I can feel the water circulation but my pc always hits 86c+ within 30 - 45min of use. And always hits 86c when idle after a while. I've tried to search it up and I can't fix the problem, and I've only had it for maybe 6 months. Are there any fixes? Or do I need to buy a new AIO. Thanks.

3 hours ago, bmx6454 said:

what are the full specs of the pc, and the rad/fan configuration? have you tried remounting/re-pasting it?

I remounted/repasted twice and it works for maybe two days then goes back to over heating.

 

Gpu 3060

CPU: 3700x

Ram: 16gb

 

I have it mounted vertically on the right side

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×