Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PiHole Help

Go to solution Solved by Falcon1986,
4 hours ago, TinsellyCone241 said:

What should I do?

Did you save dhcpcd.conf and reboot the RPi for changes to take effect?

 

What does your dhcpcd.conf look like with regards to static IPs?

 

4 hours ago, TinsellyCone241 said:

and when I set the 10.0.0.254 address as my DNS server, nothing will load.

Why are you setting this as your DNS server? Do you have something at 10.0.0.254? I thought this was the local IP you wanted assigned to the RPi.

 

4 hours ago, TinsellyCone241 said:

Any help would be appreciated!

When I set up my PiHole, I took a different approach to giving the RPi a static IP: In my router, I found the list of connected clients and bound the MAC address of the RPi to a static IP address. So even if the RPi is set to DHCP, the router will always give it the same static IP and what I set as the DNS/gateway/etc. How I see it, if I need to move the RPi to another network, I won’t need to worry about changing any config files to resume normal functioning.

So I have been setting up Pi Hole on a raspberry pi 3. I have been following this tutorial, but when I plug in my pi, it says in part of the startup sequence thing "My IP adress is 192.168 etc followed by the IPv6 address, but my router doesn't use 192.168 format. For example, the router's local IP is 10.0.0.1. I want the local IP of the pi to be 10.0.0.254 because that is a static IP. In pihole, it says 10.0.0.254 is the IP, but in rasbian linux, it says its the 192.168 one. When I try to access the dashboard, it doesn't load, and when I set the 10.0.0.254 address as my DNS server, nothing will load. What should I do? I already changed the file like in that artical where you set the static IP. Any help would be appreciated!

Link to post
Share on other sites
4 hours ago, TinsellyCone241 said:

What should I do?

Did you save dhcpcd.conf and reboot the RPi for changes to take effect?

 

What does your dhcpcd.conf look like with regards to static IPs?

 

4 hours ago, TinsellyCone241 said:

and when I set the 10.0.0.254 address as my DNS server, nothing will load.

Why are you setting this as your DNS server? Do you have something at 10.0.0.254? I thought this was the local IP you wanted assigned to the RPi.

 

4 hours ago, TinsellyCone241 said:

Any help would be appreciated!

When I set up my PiHole, I took a different approach to giving the RPi a static IP: In my router, I found the list of connected clients and bound the MAC address of the RPi to a static IP address. So even if the RPi is set to DHCP, the router will always give it the same static IP and what I set as the DNS/gateway/etc. How I see it, if I need to move the RPi to another network, I won’t need to worry about changing any config files to resume normal functioning.

Link to post
Share on other sites
1 hour ago, Falcon1986 said:

Did you save dhcpcd.conf and reboot the RPi for changes to take effect?

I did.

1 hour ago, Falcon1986 said:

What does your dhcpcd.conf look like with regards to static IPs?

See image here

1 hour ago, Falcon1986 said:

Why are you setting this as your DNS server? Do you have something at 10.0.0.254? I thought this was the local IP you wanted assigned to the RPi.

Don't you have to set the DNS server to the RPI's IP Address? I tried doing that because in the Pi-Hole setup there was an option to change the IP Address, which I did change to the local IP that I wanted (10.0.0.254). I am also unable to SSH into the RPI.

1 hour ago, Falcon1986 said:

When I set up my PiHole, I took a different approach to giving the RPi a static IP: In my router, I found the list of connected clients and bound the MAC address of the RPi to a static IP address. So even if the RPi is set to DHCP, the router will always give it the same static IP and what I set as the DNS/gateway/etc. How I see it, if I need to move the RPi to another network, I won’t need to worry about changing any config files to resume normal functioning.

I will try this. This is probably a stupid question, but how do I find the MAC address. For some reason the router won't pick up on the hostname.

Edited by TinsellyCone241
Forgot to include image link
Link to post
Share on other sites
11 minutes ago, TinsellyCone241 said:

Don't you have to set the DNS server to the RPI's IP Address? I tried doing that because in the Pi-Hole setup there was an option to change the IP Address, which I did change to the local IP that I wanted (10.0.0.254).

Oh, I see what you meant. But only change the DNS server in your router after you get PiHole up and running.

 

12 minutes ago, TinsellyCone241 said:

I am also unable to SSH into the RPI.

The "headless" setup does everything through SSH. But you'd have to place a blank and extension-less ssh file in the boot directory immediately after SD card creation.

 

17 minutes ago, TinsellyCone241 said:

This is probably a stupid question, but how do I find the MAC address.

There should be a status section in the router's webUI with the DHCP table of all connected clients.

Link to post
Share on other sites
5 minutes ago, Falcon1986 said:

There should be a status section in the router's webUI with the DHCP table of all connected clients.

There is, I was wondering how I find the MAC address of the PiHole because the hostname isn't showing properly in the WebUI of the router.

8 minutes ago, Falcon1986 said:

Oh, I see what you meant. But only change the DNS server in your router after you get PiHole up and running.

K

9 minutes ago, Falcon1986 said:

The "headless" setup does everything through SSH. But you'd have to place a blank and extension-less ssh file in the boot directory immediately after SD card creation.

I don't really need SSH, I just thought it might help diagnose the issue.

Link to post
Share on other sites
29 minutes ago, TinsellyCone241 said:

There is, I was wondering how I find the MAC address of the PiHole because the hostname isn't showing properly in the WebUI of the router.

Use the ifconfig command and see what’s listed under eth0.

Link to post
Share on other sites
15 hours ago, Falcon1986 said:

Use the ifconfig command and see what’s listed under eth0.

Awesome! It works! Thanks! I can even SSH into it now!

Link to post
Share on other sites
3 hours ago, TinsellyCone241 said:

Awesome! It works! Thanks! I can even SSH into it now!

Great!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×