Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Random average FPS drop

A s h t o n
 Share

So my average FPS has dropped in 2 games I’ve noticed, seige and OVERWATCH, I was averaging way above 200 before in both now it’s 80, this is a new pc I just built it, the thermals are good pls help me it’s really starting to annoy me lol, 2070 super i59600k 

Link to comment
Share on other sites

Link to post
Share on other sites

can you run www.userbenchmark.com and post link so we can determine well being of ur PC health, but id recomend something like

-reload default bios settings

-then back to bios and enable XMP profile for ram

-dowload latest nvidia driver https://nvidia.custhelp.com/app/answers/detail/a_id/5022/~/geforce-hotfix-driver-version-445.98

-download latest DDU uninstaller https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

-type config in start menu bar and click on system configuration, click on boot tab tick safe boot and restart

-unplug internet cable to prevent microsoft downloading older driver mid installment

-run DDU uninstaller and wipe nvidia drivers, restart

-ur pc should be back to normal mode from safe mode, if not, type config in start menu bar and open system configuration, click on boot tab, untick safe mode, restart

-install latest nvidia driver while offline still, restart pc after done

-open nvidia control panel, go under 3d settings, i HEAVLY recommend turning on sharpening at  set  sharpen 0.52 set ignore filmgrain to 0.20

-if u own 144hz monitor dont forget to switch to 144hz also in nvidia control panel under resolution

-if ur monitor supports gsync or freesync i recommend turning that ON in nvidia control panel

-Also set Low Latency Mode to ULTRA, This will reduce ur CPU usage and improve frametimes, whic provides smoother gameplay and lower cpu temps aswell

-low latency mode to ultra also locks ur fps to 137fps depending on ur monitor HZ rate

-Gsync ON, Low latency Mode ULTRA, Vertical Sync ON, ingames u turn vertical sync off

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×