Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

benjamin123

Member
  • Content Count

    30
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About benjamin123

  • Title
    Member

Recent Profile Visitors

309 profile views
  1. Thanks guys for the suggestions I guess I'll look around for a 2070 super
  2. I'm currently running a 1800x is it a good idea to get a 2080 super to go with the cpu? only games that i play in 144fps is overwatch I just need other games to look good on 60fps ps. running a 1440p 144hz monitor
  3. I know the A50 doesn't have wireless charging, so I bought a wireless charging receiver. It works on other phones except for my A50, does anyone knows what may cause this to happen?
  4. alright i'll have a go at those settings
  5. So to get started, i have a 1800x overclocked to 3.9ghz paired with a gtx 1080. I game on a 1440p, 144hz monitor. I started streaming overwatch with the x264 encoder(faster preset) and my game can't seem to hit 144fps. It always dips to 90-120fps. anyone has any idea of why this is happening? all my settings in overwatch are like the lowest and i don't think its the gpu problem. Maybe the encoder is taking up to much cpu?
  6. well guess its time to get a new monitor. ps accidently knocked over it while moving. still feeling bad about myself.
  7. So i've recently cracked some parts of my 21:9 monitor and now it looks to be a 16:9. Is it possible to move the entire display window out of the cracked area and make it 16:9 usable?
  8. alright i'll try it cheers mate
  9. @kirashi yea i plugged in to another computer and same thing happens. Not getting anything even in device manager....
  10. So i was transferring data from my pc to my hdd and it hung halfway. Stupidly enough i went to unplug the hdd and now its not even getting detected. Anyone knows if i F up big time?
  11. ryzen 1800x gigabyte ax370 gaming 5 going well for about a year and this just happened all components were the same
  12. So my pc just went into infinite boot loop Is there a solution to this? or is my mobo screwed. gpu ram and cpu are all tested and are alright.
  13. @NMS so by clearing the cmos I can reflash the bios? Because now it’s just cycling through random errors and nothing shows on screen.
  14. I can’t reflash it like nothing will show up on the screen
×