Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

New Nvidia Driver version 416.94 is broken

Crispy Customs
 Share

Hi, i came here to find out if anyone else have this issue. I just purchased Battlefield V and it requires you to install a newer driver version (416.34 or higher) to run (pop up window if you try to start it without them). I installed the driver (416.94) and started the game. Obviously SLI doesnt work cause why would it...

Tried to fix SLI myself, a few different videos and threads to help with that. Didnt work.

After alot of troubleshooting i thought that it'd be good if i tested if SLI even works on any game, given that it worked on all other games before the update.

 

Didn't work on wow, bf1, witcher etc. basically every game i tested. I reverted drivers back to what i had previous which is 399.24. SLI now works as usual on all other games i have but i can't play BFV since i dont have the driver installed.

Any tips on how to get this working or do i just sit this one out playing with 1 GPU and hope they release a new driver version ?

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, Crispybagel said:

Hi, i came here to find out if anyone else have this issue. I just purchased Battlefield V and it requires you to install a newer driver version (416.34 or higher) to run (pop up window if you try to start it without them). I installed the driver (416.94) and started the game. Obviously SLI doesnt work cause why would it...

Tried to fix SLI myself, a few different videos and threads to help with that. Didnt work.

After alot of troubleshooting i thought that it'd be good if i tested if SLI even works on any game, given that it worked on all other games before the update.

 

Didn't work on wow, bf1, witcher etc. basically every game i tested. I reverted drivers back to what i had previous which is 399.24. SLI now works as usual on all other games i have but i can't play BFV since i dont have the driver installed.

Any tips on how to get this working or do i just sit this one out playing with 1 GPU and hope they release a new driver version ?

i dunno man never heard of this,maybe installing the drivers disabled sli(i know u already tried it)

i recommend rolling back to 416.34 since this is the earliest one bf5 supports if that doesn't work either you could try uninstalling everything with ddu and installing the drivers again or just wait for a new revision

Link to comment
Share on other sites

Link to post
Share on other sites

Try beta drivers. Battlefield games have always had their issues with Nvidia drivers at launch.

^^^^ That's my post ^^^^
<-- This is me --- That's your scrollbar -->
vvvv Who's there? vvvv

Link to comment
Share on other sites

Link to post
Share on other sites

5 hours ago, ki8aras said:

i dunno man never heard of this,maybe installing the drivers disabled sli(i know u already tried it)

i recommend rolling back to 416.34 since this is the earliest one bf5 supports if that doesn't work either you could try uninstalling everything with ddu and installing the drivers again or just wait for a new revision

 

2 hours ago, LoGiCalDrm said:

Try beta drivers. Battlefield games have always had their issues with Nvidia drivers at launch.

i uninstalled the driver completely then reinstalled the latest one from geforce experience and it worked out. although i get a lot of flickering and other wierd stuff when i run BFV in SLI

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×