Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

NEw GPU No display

RicoTHeSauve
 Share

I recently got a new gpu so i can play games more smoothly and when i turn it on, it RGBand spins fans but ti shows no display on my monitor andsays not connected. I have tried uniilsatting the curtrent driver and it has not helped.... any suggestions? oh BTW all parts are compaitable so its not that.... i went from nivida 9800gt to a rx 570 and im on the 9800 gt rn andInsert other media it works fine

Link to comment
Share on other sites

Link to post
Share on other sites

What happens when you turn o. Your computer, does everything start normally and all fans spinning? 

 

Does the gpus fans also spin? 

🌲🌲🌲

Judge the product by its own merits, not by the Company that created it.

Link to comment
Share on other sites

Link to post
Share on other sites

one question have you completely uninstalled all nvidia drivers

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, andyme said:

one question have you completely uninstalled all nvidia drivers

I saw i didnt need to jsut elave them disabled but it didnt work, so i usesd DDU to do then then i came into a problem of not beign babel to log in my windows 10 becuase i ue my pin and dont know my password.... sop righht now im waiting for windows to completel reinstall i had to restart it

Link to comment
Share on other sites

Link to post
Share on other sites

soa fter clean install of windows nolonger drivers ti wxstil ahs same issues. and eys teh fans spin;

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×