Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Display output crashing

Sometimes when I'm playing R6 and then the prep phase started my display suddenly disappear, but I can still the sound of the game and my friends on discord but they can't hear me.

Things I tried:
*Switching On/Off the monitor

*Restarting the PC

PC turns on but no display.

 

What I did to fix it:

*Pushed the power button to shutdown

*Unplugged the HDMI and Power connector of the monitor

and then it powers on.

 

System

  • CPU
    Amd Ryzen 5 2600
  • Motherboard
    Asus TUF B450M-Plus Gaming
  • RAM
    16GB (8GB x 2) 1333MHz
  • GPU
    PowerColor Radeon RX 580
  • PSU
    Corsair VS450 450W
Link to comment
Share on other sites

Link to post
Share on other sites

It sounds like the display driver crashed and did not successfully recover.

 

Next time this happens, press these keys all at the same time (for Windows 10)

Win + Ctrl + Shift + B keys.

 

Good Luck!

- If it ain't broken, don't fix it! - - Your post codes and beep codes in the drop down below -

Competitive Benching Team - Warp9-Systems 

Save the old OC forums just by reading old school tec

https://forums.extremeoverclocking.com/index.php

They have the best F@H stats too. 

Spoiler

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Thank you, I'll try this when this happens again.
last time my pc didn't detected the GPU driver and so I reinstalled it.

Link to comment
Share on other sites

Link to post
Share on other sites

Sadly it didn't work.

I heard the beep but after that no more display output on my monitor no more sounds, but the cpu and case fans still running and the gpu fans keeps ramping up.

 

should I upgrade any of my Hardwares?

Link to comment
Share on other sites

Link to post
Share on other sites

Maybe diagnose the issue before upgrades.

 

Have you tried to clear cmos yet?

- If it ain't broken, don't fix it! - - Your post codes and beep codes in the drop down below -

Competitive Benching Team - Warp9-Systems 

Save the old OC forums just by reading old school tec

https://forums.extremeoverclocking.com/index.php

They have the best F@H stats too. 

Spoiler

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Running the game in Vulkan kinda fixed it.

Thanks anyway.

but if it crashed again I'll try clearing the cmos.

Thank very much for helping. 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×