Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

What is causing DXGI_ERROR_DEVICE_REMOVED?

NickPato
 Share

Hey guys, so around two weeks ago I built my first PC to mainly play iRacing and other racing sims, these are the specs:

AMD Ryzen 5 2600

Gigabyte Geforce RTX 2060 OC

G, Skill Aegis 16GB RAM

EVGA 450w PSU

Gigabyte B450m DS3h Mobo

 

After installing iRacing i started getting some crashes and in the crash log it always said DXGI_ERROR_DEVICE_REMOVED. After the initial crashes I changed a few settings and reduced the factory OC on the GPU and iRacing ran fine for a week with no crashes. Recently however the crashes are back and more frequent than ever. The game freezes and after about 10 seconds it closes itself. After these further crashes I found a video which suggested I go into the registry and add a TdrLevel and set it to 0. After this the game still crashes but now my entire PC freezes and I have to hard reset it. I have emailed iRacing support, and posted on their forums and subreddit but it was no help. I am totally at a loss as to what I should do? How do I know which one of my parts is causing this? I assume it is my GPU but I would hate to get a replacement and then find out that it was a different component causing the problem. If someone can offer any help I would appreciate it, thank you.

 

Edit: I should add that I also benchmarked my GPU and it ran fine under max load and temps did not go too high. When playing iRacing the GPU load is around 30-50%.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×