Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

New pc build help

Speci5
 Share

I know everything is receiving power, because of leds and rgb lighting, but I cant connect to my display, monitor, via hdmi.

Link to comment
Share on other sites

Link to post
Share on other sites

There is a ton that can be wrong, and you've given no info. Give us a spec list via pcpartpicker.com

I WILL find your ITX build thread, and I WILL recommend the SIlverstone Sugo SG13B

 

Primary PC:

i7 8086k (won) - EVGA Z370 Classified K - G.Skill Trident Z RGB - WD SN750 - Jedi Order Titan Xp - Hyper 212 Black (with RGB Riing flair) - EVGA G3 650W - dual booting Windows 10 and Linux - Black and green theme, Razer brainwashed me.

Draws 400 watts under max load, for reference.

 

Linux Proliant ML150 G6:

Dual Xeon X5560 - 24GB ECC DDR3 - GTX 750 TI - old Seagate 1.5TB HDD - dark mode Ubuntu (and Win7, cuz why not)

 

How many watts do I need? Seasonic Focus thread, PSU misconceptions, protections explainedgroup reg is bad

Link to comment
Share on other sites

Link to post
Share on other sites

9 minutes ago, Rev Games said:

Make sure your cpu power is connected. Lemme know if that doesnt work. 

That did not work

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Speci5 said:

That did not work

Make sure the pci 16 is properly seated and clipped in.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×