Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Misalligned GPU Short Circuit

While I receiver a new GPU EVGA 2070 today and was eager to replace it with my 1060. I put it in the MOBO and was ready to test it. As I turned on the PSU, I was ready to hit the power button. Before hitting the power button, the MOBO was the only component on. I hit the power button and nothing happened. The MOBO stayed on, but no other components turned on. We tried troubleshooting a little to see if anything was unplugged. Everything was still doing the same thing. Then we tried reseating the GPU. After, it finally worked. All the components are working fine, except the fact that my power supply does not have enough power for the build now. To my thought, was the GPU shorting out the computer? Is there any repercussions to turning on the computer during the misalignment of the 2070?  

Link to comment
Share on other sites

Link to post
Share on other sites

 

If it works it works, no repercussions if it's working now. Leaving something unplugged will seldom cause harm to your PC. 

 

As for your PSU, just don't run any heavy benchmarks, mine BTC or play BF5 with Ray-tracing enabled and you should be fine. Without the turing cores active an RTX 2070 should draw around the same amount of power as a GTX 1060 6GB.

If you DO max out your power supply it should just turn itself off to save itself from harming your system.


That being said, not all PSUs are made the same, get a nice reputable power supply when/if you upgrade.

My rig:

CPU: Ryzen 5 3600 3.6Ghz, OC'ed to 4.2Ghz all core @ 1.325ghz + Corsair H60 120mm AIO

MB: Gigabyte B450 I Aorus Pro WiFi

RAM: G.Skill TridentZ 16GB (2 x 8GB) 3200Mhz 16-18-18-38 XMP enabled

GPU: Gigabyte RTX 2080 Super

*bought for $200 CAD off a friend who needed an RTX 3080, price was my reward.

CASE: InWinn A1 Plus in White with included 600w gold sfx PSU and included custom length cables

DISPLAY: 3x 20" AOC 1080p 60hz 4ms ,  32" RCA 1080p/60 TV mounted above, all on a single arm.

 

Storage: C : 1TB WD Blue NVMe      D : 2TB Barracuda      E: 240GB Kingston V300 (scratch drive)

NAS: 240GB Kingston A400 + 6x 10+ year old 700GB Barracuda drives in my old FX8350+8GB DDR3 system

Mining Rack: 240GB Kingston A400 + 5x RX 580 8GB + 2x GTX 1070 + 1x GTX 1660ti + 6GB DDR3 + Core2Quad Q6600

 

Logitech G15 1st Gen + Logitech G602 Wireless

Steam Controller + Wired XB1 controller + Logitech G29 Racing Wheel + Wingman Extreme Digital 3D Flight Stick

Sennheiser HD 4.40 Headphones + Pixel Buds 2 + Logitech Z213 2.1 Speakers

 

My Girlfriends Weeb-Ass Rig:

Razer Blade Pro 17 2020

10th Gen i7 10875H 8c/16t @5.1ghz 

17.3" 1080p 300Hz 100% sRGB, factory calibrated, 6mm bezel

RTX 2070 Max-Q 8GB

512GB generic NVMe

16GB (2x8GB) DDR4 3200Mhz

Wireless-AX201 (802.11a/b/g/n/ac/ax), Bluetooth® 5.1, 2.5Gbit Ethernet

70.5 Whr Battery

Razer Huntsman Quartz, Razer Balistic Quartz, Razer Kraken Quartz Kitty Heaphones

*deep breath*

Razer Raptor 27" monitor, IT'S BEAUTIFUL.

Link to comment
Share on other sites

Link to post
Share on other sites

Just noticing now that you didn't post what CPU you're using or the wattage of your PSU. Who knows, what you have might be fine  ¯\_(ツ)_/¯

My rig:

CPU: Ryzen 5 3600 3.6Ghz, OC'ed to 4.2Ghz all core @ 1.325ghz + Corsair H60 120mm AIO

MB: Gigabyte B450 I Aorus Pro WiFi

RAM: G.Skill TridentZ 16GB (2 x 8GB) 3200Mhz 16-18-18-38 XMP enabled

GPU: Gigabyte RTX 2080 Super

*bought for $200 CAD off a friend who needed an RTX 3080, price was my reward.

CASE: InWinn A1 Plus in White with included 600w gold sfx PSU and included custom length cables

DISPLAY: 3x 20" AOC 1080p 60hz 4ms ,  32" RCA 1080p/60 TV mounted above, all on a single arm.

 

Storage: C : 1TB WD Blue NVMe      D : 2TB Barracuda      E: 240GB Kingston V300 (scratch drive)

NAS: 240GB Kingston A400 + 6x 10+ year old 700GB Barracuda drives in my old FX8350+8GB DDR3 system

Mining Rack: 240GB Kingston A400 + 5x RX 580 8GB + 2x GTX 1070 + 1x GTX 1660ti + 6GB DDR3 + Core2Quad Q6600

 

Logitech G15 1st Gen + Logitech G602 Wireless

Steam Controller + Wired XB1 controller + Logitech G29 Racing Wheel + Wingman Extreme Digital 3D Flight Stick

Sennheiser HD 4.40 Headphones + Pixel Buds 2 + Logitech Z213 2.1 Speakers

 

My Girlfriends Weeb-Ass Rig:

Razer Blade Pro 17 2020

10th Gen i7 10875H 8c/16t @5.1ghz 

17.3" 1080p 300Hz 100% sRGB, factory calibrated, 6mm bezel

RTX 2070 Max-Q 8GB

512GB generic NVMe

16GB (2x8GB) DDR4 3200Mhz

Wireless-AX201 (802.11a/b/g/n/ac/ax), Bluetooth® 5.1, 2.5Gbit Ethernet

70.5 Whr Battery

Razer Huntsman Quartz, Razer Balistic Quartz, Razer Kraken Quartz Kitty Heaphones

*deep breath*

Razer Raptor 27" monitor, IT'S BEAUTIFUL.

Link to comment
Share on other sites

Link to post
Share on other sites

8 minutes ago, ScarletSpeed10 said:

Is there any repercussions to turning on the computer during the misalignment of the 2070?  

if it works fine afterwords and gets a solid score in a benchmark it should be fine

not sure what could be wrong with it since it looks like it wasn't damaged since it worked afterwords

 

8 minutes ago, ScarletSpeed10 said:

my power supply does not have enough power for the build now.

get a new one as soon as you can something like a evga 650w

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Chronified said:

Just noticing now that you didn't post what CPU you're using or the wattage of your PSU. Who knows, what you have might be fine  ¯\_(ツ)_/¯

Premature ejaculation poster. xD

Link to comment
Share on other sites

Link to post
Share on other sites

30 minutes ago, Chronified said:

Just noticing now that you didn't post what CPU you're using or the wattage of your PSU. Who knows, what you have might be fine  ¯\_(ツ)_/¯

Hi Chronified, 

i have a i7 7700 k and a 650 w Golden evga power supply. I just bought a 1000 w to replace the 650. Do you this will run fine. Also do you know the average FPS of a 2070. Running Furmark stated 160.

Thank you!

Link to comment
Share on other sites

Link to post
Share on other sites

33 minutes ago, Happycowdance said:

if it works fine afterwords and gets a solid score in a benchmark it should be fine

not sure what could be wrong with it since it looks like it wasn't damaged since it worked afterwords

 

get a new one as soon as you can something like a evga 650w

I have a evga 650 w. I just purchased at evga G3 1000 w

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, ScarletSpeed10 said:

Hi Chronified, 

i have a i7 7700 k and a 650 w Golden evga power supply. I just bought a 1000 w to replace the 650. Do you this will run fine. Also do you know the average FPS of a 2070. Running Furmark stated 160.

Thank you!

The load wattage between your CPU+GPU is only 380w if you're completely maxing the system.

I'd say the 1000w processor is pointless, you're fine with what you have now unless you plan on getting a 2nd RTX 2070 to run in NVlink or have 6+ HDDs in the system

My rig:

CPU: Ryzen 5 3600 3.6Ghz, OC'ed to 4.2Ghz all core @ 1.325ghz + Corsair H60 120mm AIO

MB: Gigabyte B450 I Aorus Pro WiFi

RAM: G.Skill TridentZ 16GB (2 x 8GB) 3200Mhz 16-18-18-38 XMP enabled

GPU: Gigabyte RTX 2080 Super

*bought for $200 CAD off a friend who needed an RTX 3080, price was my reward.

CASE: InWinn A1 Plus in White with included 600w gold sfx PSU and included custom length cables

DISPLAY: 3x 20" AOC 1080p 60hz 4ms ,  32" RCA 1080p/60 TV mounted above, all on a single arm.

 

Storage: C : 1TB WD Blue NVMe      D : 2TB Barracuda      E: 240GB Kingston V300 (scratch drive)

NAS: 240GB Kingston A400 + 6x 10+ year old 700GB Barracuda drives in my old FX8350+8GB DDR3 system

Mining Rack: 240GB Kingston A400 + 5x RX 580 8GB + 2x GTX 1070 + 1x GTX 1660ti + 6GB DDR3 + Core2Quad Q6600

 

Logitech G15 1st Gen + Logitech G602 Wireless

Steam Controller + Wired XB1 controller + Logitech G29 Racing Wheel + Wingman Extreme Digital 3D Flight Stick

Sennheiser HD 4.40 Headphones + Pixel Buds 2 + Logitech Z213 2.1 Speakers

 

My Girlfriends Weeb-Ass Rig:

Razer Blade Pro 17 2020

10th Gen i7 10875H 8c/16t @5.1ghz 

17.3" 1080p 300Hz 100% sRGB, factory calibrated, 6mm bezel

RTX 2070 Max-Q 8GB

512GB generic NVMe

16GB (2x8GB) DDR4 3200Mhz

Wireless-AX201 (802.11a/b/g/n/ac/ax), Bluetooth® 5.1, 2.5Gbit Ethernet

70.5 Whr Battery

Razer Huntsman Quartz, Razer Balistic Quartz, Razer Kraken Quartz Kitty Heaphones

*deep breath*

Razer Raptor 27" monitor, IT'S BEAUTIFUL.

Link to comment
Share on other sites

Link to post
Share on other sites

8 minutes ago, Chronified said:

The load wattage between your CPU+GPU is only 380w if you're completely maxing the system.

I'd say the 1000w processor is pointless, you're fine with what you have now unless you plan on getting a 2nd RTX 2070 to run in NVlink or have 6+ HDDs in the system

I have two other solid states and led fans. Right now the LED are dim, but the fans are running. There are 8 fans around the case

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, ScarletSpeed10 said:

I have two other solid states and led fans. Right now the LED are dim, but the fans are running. There are 8 fans around the case

yeah man, you're fine with a 650w

image.png.32cb4084acd5ec4e2a2791476619b4c6.png

PSU Calc says your max load would be 404w

http://www.coolermaster.com/power-supply-calculator/

My rig:

CPU: Ryzen 5 3600 3.6Ghz, OC'ed to 4.2Ghz all core @ 1.325ghz + Corsair H60 120mm AIO

MB: Gigabyte B450 I Aorus Pro WiFi

RAM: G.Skill TridentZ 16GB (2 x 8GB) 3200Mhz 16-18-18-38 XMP enabled

GPU: Gigabyte RTX 2080 Super

*bought for $200 CAD off a friend who needed an RTX 3080, price was my reward.

CASE: InWinn A1 Plus in White with included 600w gold sfx PSU and included custom length cables

DISPLAY: 3x 20" AOC 1080p 60hz 4ms ,  32" RCA 1080p/60 TV mounted above, all on a single arm.

 

Storage: C : 1TB WD Blue NVMe      D : 2TB Barracuda      E: 240GB Kingston V300 (scratch drive)

NAS: 240GB Kingston A400 + 6x 10+ year old 700GB Barracuda drives in my old FX8350+8GB DDR3 system

Mining Rack: 240GB Kingston A400 + 5x RX 580 8GB + 2x GTX 1070 + 1x GTX 1660ti + 6GB DDR3 + Core2Quad Q6600

 

Logitech G15 1st Gen + Logitech G602 Wireless

Steam Controller + Wired XB1 controller + Logitech G29 Racing Wheel + Wingman Extreme Digital 3D Flight Stick

Sennheiser HD 4.40 Headphones + Pixel Buds 2 + Logitech Z213 2.1 Speakers

 

My Girlfriends Weeb-Ass Rig:

Razer Blade Pro 17 2020

10th Gen i7 10875H 8c/16t @5.1ghz 

17.3" 1080p 300Hz 100% sRGB, factory calibrated, 6mm bezel

RTX 2070 Max-Q 8GB

512GB generic NVMe

16GB (2x8GB) DDR4 3200Mhz

Wireless-AX201 (802.11a/b/g/n/ac/ax), Bluetooth® 5.1, 2.5Gbit Ethernet

70.5 Whr Battery

Razer Huntsman Quartz, Razer Balistic Quartz, Razer Kraken Quartz Kitty Heaphones

*deep breath*

Razer Raptor 27" monitor, IT'S BEAUTIFUL.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×