Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Dudefoxlive

Battery reading no voltage. Can it be revived?

Recommended Posts

Posted · Original PosterOP

I was sent a chuwi Hi10 Pro from a friend because it won't turn on. After taking it apart I have determined that the devices battery is 100% dead. When testing with a multi meter I was reading 0 voltage on the battery. Since this battery is soldered onto the motherboard and I can't seem to locate a replacement or used battery on ebay or amazon I am left with trying to revive this one. Right now I have it on the charger and am just letting it charge overtime hoping that it will revive itself. What should I do to try and help this?

Link to post
Share on other sites
33 minutes ago, Dudefoxlive said:

I was sent a chuwi Hi10 Pro from a friend because it won't turn on. After taking it apart I have determined that the devices battery is 100% dead. When testing with a multi meter I was reading 0 voltage on the battery. Since this battery is soldered onto the motherboard and I can't seem to locate a replacement or used battery on ebay or amazon I am left with trying to revive this one. Right now I have it on the charger and am just letting it charge overtime hoping that it will revive itself. What should I do to try and help this?

Ah, gonna turn you onto AliExpress today. Looks like they have what you need at a reasonable price!

 

 

https://www.aliexpress.com/item/32959607546.html?spm=a2g0o.productlist.0.0.7903fd91wcWK2g&algo_pvid=5d100d4b-a0dc-4fca-8122-56c9854ca651&algo_expid=5d100d4b-a0dc-4fca-8122-56c9854ca651-1&btsid=0ab50f4915914933888912184e2bf6&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_

 


 

Lid-less PGA 2700x / ROG B450-I Gaming / Corsair 3000mhz SK Hynix / RTX 2060 / EVGA 750w

Lid-less 8700K / Maximus X Hero / G.Skill 4266mhz B-Die / RTX 2060 / Antec 1000w CP series

Ryzen Athlon 220ge with Vega Graphics / Asus Prime B450M-A / Corsair LED 3000mhz / 550w Antec Office PC.

DFI LanParty UT / Opteron 148 / DDR Corsair XMS Expert / X1800 XT 256MB Bios modded

Asus CrossHair Formula IV / Phenom II x4 B97 / Dominator GT 2000mhz. / EVGA GTX 770

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×