Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PorumbFlorin

Member
  • Content Count

    5
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About PorumbFlorin

  • Title
    Newbie
  • Birthday 1987-01-26

Contact Methods

  • Heatware
    Florin

Profile Information

  • Gender
    Male
  • Location
    United Kingdom
  • Interests
    Gaming, PC Build

System

  • CPU
    i9 9760x
  • Motherboard
    ASUS Rampage VI Extreme
  • RAM
    64 GB DDR 4 BallistiX
  • GPU
    ASUS RTX 2080 Ti
  • Case
    Cooler Master
  • Storage
    2SSD 970 EVO Samsung
  • PSU
    Corsair RM 1000W
  • Display(s)
    ACER Predator
  • Cooling
    Hybrid Cooler Master 2.0
  • Operating System
    Win 10

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. PorumbFlorin

    DEAD RTX 2080Ti ?

    I herd of those cases as well, and you never think is gonna' happen to you until it does. And it sucks ! I was getting ready for Metro Exodus... now i'm left with mobile legends ...wtf
  2. PorumbFlorin

    DEAD RTX 2080Ti ?

    Just changed the cables, still the same err.. I guess i will submit a replace form . I cant believe i have to replace a 2080 ti so soon. Funny thing (or not), it happen while i was playing Resident Evil 2. And when you press START GAME, the name of the game cranks on the screen. I pressed that, and it f...up my VGA :(((( Thanks for the help guys.
  3. PorumbFlorin

    DEAD RTX 2080Ti ?

    I will do that, i will change the cables and i will give a reply asap
  4. PorumbFlorin

    DEAD RTX 2080Ti ?

    Thanks for the reply. The thing is ( i just want to make sure ), is that a hardware issue or a software one ? Based on that error. It might sound stupid, but i'm not really into these things. And, any ideas WHAT was the cause ? Thank you
  5. PorumbFlorin

    DEAD RTX 2080Ti ?

    Hello guys. Specs : ASUS Rampage VI Extreme i9 7960X ASUS RTX 2080 Ti 64 GB DDR 4 Problem : I was in gaming, and system shut down. At restart, on the MB display, i get this error : B2 Load VGA BIOS What i've tryed : Only one stick or RAM, moved the GPU on different slots, BIOS update (on MB), CMOS clean... nothing, I cant even get into BIOS. Is anythig to be done or shoud i call for a replacement ? Thanks allot
×