Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

ThomasJacobsen

Member
  • Content Count

    90
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About ThomasJacobsen

  • Title
    Member

Contact Methods

  • Star Citizen
    1998

Profile Information

  • Gender
    Not Telling
  • Location
    Norge
  • Interests
    Making poor decisions + Semi weeb
  • Biography
    I have a hate/ love relationship with CS:GO + LoL, Crashing racecars in AC is my hobby
  • Occupation
    Student

System

  • CPU
    i5-7400
  • Motherboard
    MSI B250M BAZOOKA
  • RAM
    2X4GB 2400MHz Crucial + 2x4GB 2600MHz Ballistix
  • GPU
    Zotac 1060 3GB
  • Case
    BitFenix Nova
  • Storage
    156GB Kingston SSD + 1TB Seagate Barracuda
  • PSU
    EVGA 500W 80+
  • Display(s)
    AOC 24" 1080p
  • Cooling
    Intel poor mans stock
  • Keyboard
    Razer BlackWidow Chroma V2 Orange Switches
  • Mouse
    DeathAdder 2013
  • Sound
    Arctis Pro Wireless

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. hm, ill just try retarting the pc once in a while and see if the problem persists, thanks
  2. Should be, fired right up when i installed the 3600. It's been working for a couple of weeks no problem, can it just break randomly?
  3. After i went into bios to fix fan profile, it didnt post again with no changes other than fan profile. When i reset bios again it launched fine and when i changed fan profile before booting into windows it went fine and pc is currently working It's just annoying if i need to reset bios every time i reboot the pc
  4. The problem here is that even after bios reset, it's still not posting if I turn it off again. Need to reset cmos everytime I think
  5. I tried to overclock my ram by just changing the speed in BIOS and now it won't post with orange light. I managed to get it to boot into windows by resetting the bios, but when I tried to go and change the fan profile in BIOS later it would not boot again with new orange light. Any idea what's happening?
  6. Norway got insane customer focused laws, but we pay 25% extra dont be too bummed about your 2-3 years I figure i will loose warranty too, but im not overclocking either so doesnt really matter!
  7. No point in buying a slower card for the same price Thank you! I will probably buy a 2060 and cry myself to sleep after spending 1500 over my original budget
  8. Would a used 1070ti be worth the slow RMA over a 2060? 1070ti used is about the same as a 2060 new
  9. Yeah, am 100% i cant get anything over a Rx590 (AMD- side) without getting a bigger PSU, so the Vegas are pretty much out of question..
  10. Not quite, as the site sometimes gets prices from Ebay. Used cards cant be compared to new ones.. But obviously if i'm going for the mid- range cards its going to be the 2060, as it stands out in bang for buck like the site says!
  11. In short: long term, get the 2060? (Future ray tracing titles + future 144hz monitor) The RMA is about 2 weeks over here, sometimes even shorter. Also, the i5 7400 isnt too weak for a 2060?
  12. Pricing is all wrong, we have 25% tax over here Also, there is only 1 card under 400$ there! Otherwise that website is great, i'm just afraid of bottlenecking..
  13. Assetto Corsa, Forza, Battlefield 1, Anthem i guess (dont have a gpu rn ), Assasins Creed,Maybe modded Skyrim, Dirt 2.0, Cyberpunk The 590 is only 10% better than 580, so i dont know if its worth it.. Note: A used 1070 is about 100-120CAD cheaper than new, and we always have 5 year warranty on stuff like that by law in Norway.
×