Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Using two distinct networks between two computers

Final Progeny
 Share

Hi there,

 

So I'm in a bit of a pickle with regards to my particular setup. I'm running two computers, one acting as my backup and storage server, and another I use for my work. My two PCs are connected as such:

External Network (standard 192.168.0.x/24 address) (100Mbps)

Work PC -Ethernet- Router -WiFi- Server

 

The original Ethernet connection that was put in was only a 100Mb link, so when transferring 10's of GBs of data, it can take hours. To circumvent this, we put in a direct wired connection using Gigabit Ethernet.

Internal Only Network (10.0.0.x/8 address) (1000Mbps)

Work PC - Ethernet - Server

 

So my problem is that, even though the Internal network is faster, when using network shares to the server, Windows seems to be aggregating the two links, which are both capable of reaching the Server, which means that while it is a speed increase over the maximum Megabit speeds, it is running about 45% the maximum speed of Gigabit.

 

If I disable the External Network on the Work PC, the transfer speeds immediately shoot up to maximum Gigabit speeds, but this means that I lose internet connectivity, as I'm no longer connected to the router. The reason my Server is also connected to the router is due to the wifi, which allows me to access it from other devices in my home, as well as across the internet, so disabling the internet connection there is also not an option.

 

I was under the impression that Windows would see the faster link, and just use that, especially as I explicitly state to use a UNC path of \\10.0.0.x to access the server, and not a hostname.

 

Is there a way that I can ensure that traffic specifically directed to / from the 10.0.0.x network is not aggregated across the slower link? Do I need to mess with the route tables on both machines, or can I setup a firewall on the server to block traffic from a certain IP on a particular Physical Ethernet port?

 

Any help appreciated, thanks.

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

What device are you using? And I believe you said you have 2 PCs? (One Home PC, One Server)? Do both have 1Gbps Ethernet connection? Are both connected to the Giga ports? Is your server in a virtual machine? or it's one machine, with one OS, same for Home PC?

Security Analyst & Tech Enthusiast

Ask me anything.

Link to comment
Share on other sites

Link to post
Share on other sites

Yes, both PCs are using a Gigabit connection. The server is just running Windows 10 for network shares. The Work PC is also Windows 10.

Link to comment
Share on other sites

Link to post
Share on other sites

The easiest option would be to address the network shares by IP address, that way it should only go out of the corresponding adapter for that range.  As I'm guessing you are already using static IP addresses this should be extremely easy.

Router:  Quotom-Q555G6-S05 running pfSense WiFi: Zyxel NWA210AX (~940Mbit peak)

Switches: Netgear MS510TXUP, Netgear MS510TXPP, Netgear GS110EMX
ISPs: Zen VDSL (~74Mbit) + VOXI 4G [Vodafone] (~120Mbit) + Three 5G (~500Mbit average)

Link to comment
Share on other sites

Link to post
Share on other sites

That is unfortunately what I'm already doing. Accessing the server via \\10.0.0.1 vs \\192.168.0.1 still shares the bandwidth between both adapters.

Link to comment
Share on other sites

Link to post
Share on other sites

That doesn't make sense as there is no way your PC should know it can reach 10.0.0.1 from the 192.168.0.1 adapter, vice versa.

 

Failing that, plugging the 100Mbit connection into a Gigabit switch then both PCs into that Switch should do the trick.

Router:  Quotom-Q555G6-S05 running pfSense WiFi: Zyxel NWA210AX (~940Mbit peak)

Switches: Netgear MS510TXUP, Netgear MS510TXPP, Netgear GS110EMX
ISPs: Zen VDSL (~74Mbit) + VOXI 4G [Vodafone] (~120Mbit) + Three 5G (~500Mbit average)

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×