Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Is my cpu dead? *solved*

 Share

I am building a computer with my friend and I think the cpu might be dead but don't know, 

 

When I short the connectors to start the computer the pump leds light up and the ram lights up then the cpu led lights up on the board and then everything turns off

 

The components are:

Corsair h100x

Rog strix z370 h gaming

I7 6700k

Corsair vengeance ram

 

I have tried reseeding both the 24pin and 8pin cpu, tried booting with only 1 stick of ram (tried both individually to see if the issue was the ram) 

 

I don't think it's a problem with the board as none of the pins on the socket are bent and the power light comes on so it doest seem to be a short, 

 

I have tried clearing cmos just to see if it would work, it didn't, 

 

I have put in a speaker to see if there are any error beeps, there are none. 

 

If anyone has any idea on weather or not the cpu is dead any help would be appreciated thanks 

Link to comment
Share on other sites

Link to post
Share on other sites

The 6700K won't work an Z370 board, the CPU needs to be a 8th or 9th gen (BIOS update needed). 

زندگی از چراغ

Intel Core i7 7800X 6C/12T (4.5GHz), Corsair H150i Pro RGB (360mm), Asus Prime X299-A, Corsair Vengeance LPX 32GB (4X4GB & 2X8GB 3000MHz DDR4), MSI GeForce GTX 1070 Gaming X 8G (2.113GHz core & 9.104GHz memory), 1 Samsung 970 Evo Plus 1TB NVMe M.2, 1 Samsung 850 Pro 256GB SSD, 1 Samsung 850 Evo 500GB SSD, 1 WD Red 1TB mechanical drive, Corsair RM750X 80+ Gold fully modular PSU, Corsair Obsidian 750D full tower case, Corsair Glaive RGB mouse, Corsair K70 RGB MK.2 (Cherry MX Red) keyboard, Asus VN247HA (1920x1080 60Hz 16:9), Audio Technica ATH-M20x headphones & Windows 10 Home 64 bit. 

 

 

The time Linus replied to me on one of my threads: 

 

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, LinusTechTipsFanFromDarlo said:

The 6700K won't work an Z370 board, the CPU needs to be a 8th or 9th gen (BIOS update needed). 

Ah yes I see now, thanks

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×