Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Unrefreshing Refresh Rates

scroome
 Share

Hey all,

 

So I bought myself an RX580 from eBay a couple months back, and have been happily catching up on my steam list, and enjoying the upgrade.

I just finished the Witcher 3, running at 1440p maxed, and was pretty impressed with the performance. I then decided to push the envelope a little further and install Shadow of the Tomb raider.

When going through the settings, I noticed that the game had selected 30Hz as a default. No problem, I thought, I'll change it to 60Hz, as this is the native selection for my TV (TCL 5 Series). As soon as I changed the refresh to 60Hz, the screen began to flicker and I got a mixture of sparkles, Green Screen or Black screen, mixed in with the game menu.

I changed it back to 30Hz, and immediately the problem stopped. My first thought was to try 1080p, with 60Hz. No problems there. I tried changing the Hz on a few different games, and every time I changed to 60, it immediately became unstable, but ran fine on 30Hz.

My second thought was to replace the HDMI cable, as I thought that maybe it wasn't able to cope. I purchased a Members Mark HDMI cable from Sam's Club, as I was in the area and the cable stated it could handle 18Gbps transfer speeds, which should have been enough for 1440p at 60Hz. Got home, swapped the cables, tried it all again and Bam same problem.

I tried a fresh install of drivers from AMD (18.11.2) and checked the BIOS version, which is the same as current, according to XFX (GTS XXX 8GB Edition - 015.050.002.001.000000).

The only thought that I had, was that this card either has a faulty HDMI socket, or that something else happened to the card (I have a strong feeling it was used for mining) with the previous owner.

 

So, to summarize:


1080p 60Hz on TV - No issues (tried a couple more games, and they're all fine)
1440p or higher at 30Hz - No issues, but crazy screen tear in games without V-Sync (some games like Assassins Creed and Tomb Raider have V-sync unchangeable, for some reason)
1440p or higher at 60Hz - Screen Sparkles, Black out, Green out, sound cutting (Running sound through HDMI)

Tried Adjusting Refresh in Windows, to 59Hz - No change (50Hz is not available to select. It only goes between 60, then 30)
Tried getting a new HDMI cable that can handle 18Gbps - No change
Tried playing with the settings on my TV, to see if that would alter anything - No change (including manually selected HDMI 2.0 in my TV settings. This lessened the effect, but it still seems to be occurring)

Tried using a different TV, which has 60Hz native - No change

Windows 10 Runs fine at 4K with 60Hz. No issues with things like youtube running, or Netflix. As soon as something taxing like a game comes on, it throws a fit.

I guess my next step would be to try a displayport to HDMI adapter for the cable I have, and see if that works. Other than that, I'm kinda stumped.

Any help would be hugely appreciated

Link to comment
Share on other sites

Link to post
Share on other sites

It sounds like the scaler in your TCL TV might have not been designed for 1440p above 30 Hz, or at the very least wasn't validated at that resolution.  It's been a while since I've used an AMD GPU, but is there a setting in the control panel that will force scaling to be on the GPU?  This should run your TV at its native 4k 60 Hz (that is its native, right?) and the GPU will do the conversion to 1440p instead of the TV scaler.  This might be a good bypass.

Link to comment
Share on other sites

Link to post
Share on other sites

I think you could be right there. I tried running Shadow of the Tomb Raider again: 

 

This time I set it to 1440p with 60Hz refresh. I then enabled V-Sync at half refresh rate and it ran without a hiccup (at solid 30fps, which is not ideal). Same for native 4k (obviously not at 30fps :))

 

Strange thing is; If I run it at 1440p 60Hz without V-Sync and it starts to throw a fit: If I then change it to native 4k 60Hz, it behaves exactly the same. If I exit and come back in at native 4k 60Hz the effects are still visible, albeit at a much reduced level. Again if I then change it to 30Hz, the problem disappears. Same process, if I try to change it to 1080p from 1440p.

 

Interestingly enough, if I try to change my scaling settings in the AMD control panel, I get the following flash up (first attach - AMD Settings). Enabling Virtual Super Resolution appeared to make no difference, although that could be more due to the fact that I don't know how it works.

 

I've been trying to set a manual resolution (second attachment), but it tells me that it is not supported by my display, which I find odd, because the screenshot is the resolution it's filled in, by default.

 

 

 

 

 

 

AMD Settings.JPG

Custom Resolution.JPG

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×