Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

kurora

Member
  • Content Count

    4
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About kurora

  • Title
    Newbie
  • Birthday 1997-05-02

Profile Information

  • Gender
    Male
  • Location
    Indonesia

System

  • CPU
    i5 3570
  • Motherboard
    gigabyte h61m-s2p re
  • RAM
    8gb dual channel
  • GPU
    rx 580 8GB Sapphire Nitro+
  • Case
    corsair carbide 200r
  • Storage
    2x 500gb 7200rpm
  • PSU
    gx 550w 80+white

Recent Profile Visitors

33 profile views
  1. hi everyone needs help here i just bought an used msi z77a-g45 the sellers said the motherboard is works fine but when its arrive at me i installing everything it wont POST, on screen appearing a 99 code on bottom right corner of the screen, what ive tried clear cmos from the button on the motherboard remove and place again the cmos battery cleaning ram use igpu and my rx 580 removeing all port like sata usb 3 front but the power and other is still plugged i wrote some cases said that the motherboard was dead the sellers gave me a 3days warranty, if the product not work i can return it what should i do ? thaankss for the help ;))
  2. its not a 80+ bronze and its 10years old now, should i replace it asap ?
  3. thanks for the warm welcome. so i can use this for a while ? but can my rig make a sparkle if i still use this for a while ?
  4. hi im new i curious about my rig some people say that my power supply is trash, and i also miss seeing, i tough my psu was a 80+ bronze, but its only 80+ white instead should i change with my current specifications, or i can play it with no danger for my components i5 3570 h61m s2p r3 2x4gb rx 580 8gb nitro+ 4 corsair case fan 2 sata hdd thanks for the advice i really need a info
×