Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Karan Chopra

Member
  • Content Count

    41
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About Karan Chopra

  • Title
    Member
  • Birthday 2006-02-28

Contact Methods

Profile Information

  • Gender
    Male
  • Location
    India
  • Interests
    Anything related to tech whether it's PC Components like CPU,gpu,ram or Mobile Devices.
  • Biography
    My name is Karan Chopra and my life's passion is Technology.I make YouTube videos on Tech.
    Do visit my channel- Tech Domino
  • Occupation
    I m a Student.

System

  • CPU
    Intel Core 2 Quad Q9650 @3.0ghz
  • Motherboard
    Lapcare G41-?????? Motherboard
  • RAM
    4gb DDR3
  • GPU
    Inno 3D GT 710 (Overclocked by me)
  • Case
    Iball Z370 Case
  • Storage
    Toshiba 1Tb 7200rpm,WD Blue 1Tb 7200rpm
  • PSU
    Iball 450w
  • Display(s)
    LG Monitor
  • Cooling
    Intel stock cooler
  • Keyboard
    Redgear gaming keyboard
  • Mouse
    Hp m100 gaming mouse
  • Sound
    Sony 7.1 home theater
  • Operating System
    Windows 10 Home (Debloated)
  • Laptop
    Nope.

Recent Profile Visitors

271 profile views
  1. I actually installed another version of game and now it's working great. I m also using high quality textures with it and btw I have only 1 gb ram used on idle.
  2. There's 3 files in the bin32 folder named Benchmark CPU, Benchmark CPU2 and Benchmark GPU. Yeah I thought it was weird too but idk how I got 90fps avg at 720p low.
  3. I have a 1600x900 LG monitor @60hz and my pc has a core 2 duo @3ghz, 4gb ddr3 ram, 2Tb of ed blue storage and a GT 710 2gb overclocked gpu.
  4. I have a pc with a gt 710 2gb overclocked gpu and a decent core 2 quad cpu but when I start crysis one its stutters like hell even in the main menu even at 720p, but the benchmark have high fps like 90 fps. What should I do?
  5. I have a pc which was working fine till yesterday when I plugged it to my other tv and after that it stopped displaying anything on my main monitor which is a 32inch LG tv and it doesn't even display the bios it's just a black screen with nothing on it. I tried switching displays with 2 TVs and 1 VGA monitor but got no display output. Help would be really appreciated.
  6. Hey man yeah I did try all of those and reinstalled the game. It's working fine now. Thanks
  7. It was working yesterday but after connecting my pc to tv once this happened I ahve tested the speakers and they working fine but just the ingame sound is not working. Pls help
  8. I have searched for it but there's nothing like that in bios
  9. The CPU was under load as I was benching it with cinebench r20
  10. I have tried that too but it also shows the same
  11. The temps are well under 50 degrees at load and I have tried everything including switching to performance mode and changing to windows 7 as well but got nothing
  12. I have a pc with a core 2 duo which is supposed to run at 1.8ghz but the base clock shows only 0.9ghz and it also runs at that speed only. Pls help
×