Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

ChrisZH

Member
  • Content Count

    428
  • Joined

  • Last visited

Everything posted by ChrisZH

  1. So i was wondering what could cause a kink in a custom loop. I just noticed that my flow had been restricted some (thankfully didnt play any games because of school) and i have since moved it a bit and sorted the kink out. I will of course drain the loop to clean it anyways as its been close to a year now and needs to be cleaned out. But i just cant figure out why it would suddenly kink when there wasnt anything wrong before. This picture is after i moved it, but the kink was serious. Im worried something could have happened to my pump. Ive also checked for possible leaks in all places but nothing.
  2. Yea it just doesnt give me that option for my w-pump header. It allows me to see the rpm though
  3. I have asus prime x370-pro mobo. I could get a splitter for my other fan header. I just thought my pump had to go into w-pump header
  4. I can control my cpu fan and chassis fan. I got my pump plugged into the w-pump header. Figured it would be pwm control for it
  5. I was also curious how to have pwm enabled on my pump. I have the 4pin put in, but also the 12v molex cable. I cant access pwm controls. Do i need to just have the pwm cable and not the molex?
  6. Is EVA foam or Cork better for anti vibrations?
  7. How would you suggest isolating the vibrations from the pump without making it heat up?
  8. It seems like the conquer really allows vibrations everywhere lol. How would you suggest stopping them?
  9. You think im hearing it more because its complete open case? I guess i never took that into consideration. How would you handle the vibrations though? I got these foam pads that came with it, not really helping much.
  10. I love my cougar conquer case, just because you dont like it doesnt mean someone else wont.
  11. The vibrations are still there but i heard thats normal for a D5 pump right? It sounds kind of similar to the old pump, but it just does not have that kind of grindy sound to it. ughh man those vibrations are killer when your on the same desk as it... any advice? The sound doesnt really start until it starts moving a good amount of water at high speed. Idk i guess i was under the impression that there would be zero sound with this. When i was filling i made sure there was fluid inside the pump head completely and moved it around so it was everywhere. Did not want to run it dry.
  12. Also i looked at bad D5 pump, cant see anything that would be defective with it
  13. So i replaced the pump, still hear something. Maybe its bubbles but its nowhere near as bad Here is old pump for reference
  14. Im running a radeon VII and i have a 360 45mm rad up top and a 240 30mm in front. My temps for that are really good, overclocked pretty heavily. Although im using a cougar conquer case, so that could be why.
  15. Yea, thankfully learned and put a drain valve in to make it easier haha. Im really curious to see whats wrong with the pump. Or maybe its the pump top. Idk lol
  16. So frustrating to get a bad pump sent to me. Well they said they will send the pump they tested to me so i guess i have to drain the loop and put it back together when i get it
  17. Nope, did not help at all with the noise. I think i got a bad pump, because the unit was put together when i got it.
  18. You think it sounds plausible, what they think it could be?
  19. So Bykski think that the pump might be too far into the pump head and the impeller is touching it. If i loosen the screws connecting the pump to pump head will i cause a leak?
  20. I have talked with Bykski, they are trying to reproduce this issue. If they cant then they are going to send me a replacement. I do love the way this build looks though. Even with my old pump/res combo im seeing a 20c improvement from my 240 slim and 120 rad setup.
  21. So what should a d5 pump look like after taking it apart? So i have a reference?
  22. Was really hoping i wouldnt have to drain the loop again lol
  23. So only way to really tell whats going on is to open it up and see what happened? im hoping they can send me a new pump... because it was never run dry at all... this is really disappointing because all other bykski stuff ive gotten is great
  24. Also it still sounds like water bubbles traveling through my loop. I can hear these sounds... no idea what they are
  25. I heard something about how this model is plastic? Im exchanging emails with bykski, they said to mount it a different way (saying impeller is hitting inside of pump head), but why would it happen at high rpm and not lower?
×