Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

ChrisZH

Member
  • Content Count

    494
  • Joined

  • Last visited

Everything posted by ChrisZH

  1. Well I always loved the way the blade looked. That sleek look it has and from my experience with razer products, I figured it would be worth it. Honestly, if it wasn't for the fans I would have kept it. It worked great, had the power to do everything I needed it to. That noise was just something I couldn't bear, lots of others thought this as well.
  2. I recently purchased the razer blade 15 2020 model. It looks amazing, has such a premium feel to it. Keyboard isn't that good but I figured I could deal with it. I turn it on for the first time and BAM, the fans ramp up so hard it sounds like a jet engine. Turns out that on the 2020 models, there is no option to not have fans on during idle use. There's this high pitch whining sound from the laptop as well. I tried everything I could, undervolting the chip. Passive system cooling on instead of active. It gets worse though because the fan at low rpm is a lot more noticeable than when it's at me
  3. I am looking for a new laptop for school as well as gaming in my free time. I have been doing a lot of research on these laptops and I'm not sure which I should get. I am partial to the build quality for the blade 15 but I heard the G14 has decent build quality too. I am not too happy about the lack of a webcam due to the whole Covid issue still and most classes require a webcam. Do you guys have any inputs on the laptop to get?
  4. Are those within the price range of the others?
  5. I've been looking to get a wireless headset to help with gaming at night so I don't wake my wife up. From looking I see three that I'm interested in. Steelderies Arctis 1, Corsair void elite rgb, and the razer nari essential. They are all the same price but I just don't know what to get. Does anyone have any suggestions, or have experience with any of these headsets?
  6. Well for the Aorus monitor people are saying it's an innolux panel. The same as my current Acer monitor. I really wish my monitor didn't have these problems because it's amazing otherwise. Started happening after I couldn't return it anymore..
  7. From what I've been reading people love the LG monitor so I am really thinking about it. LG is known for their quality control right? I'm just stuck between the LG and the Aorus. The Aorus looks like the build quality is amazing, but idk about the innolux panel on it...
  8. I'm looking at the LG 27gn850-b monitor and the Aorus fi27q. They are both the same specs but I know the Aorus uses an innolux panel. The monitor I currently have uses one too and suffers from flickering/arifacting. It didn't used to do this but I am not the only one with an Acer xv272u monitor to have this. So I am kinda hesitant to get another innolux panel because of this. I have heard great things with the best buy LG monitor, but also good things about the Aorus monitor. So I am not too sure which one to buy and would appreciate any help from your opinions. If you have a different choice
  9. I'm having him use his old power supply to see what happens when he gets off work. Then I might have him use just 1 stick of ram. I'm running out of things to do for troubleshooting. This is the same problem I had with my Radeon vii. Since I upgraded to the 2080ti I haven't had any issue at all. I'm trying to get him to just upgrade his gpu, since a 580 can't do much with modern games anymore really
  10. He checked in event viewer and was a video TDR error so I guess we try to solve this and see what happens
  11. Well the crashes are random, like sometimes after 2 hours and sometimes immediately. He has the ram in the correct slot. If it's a memory issue it could be a stability issue with the BIOS. I was having the same on my x570 until I updated the BIOS version to a more recent one.
  12. Yes I thought the same as well. He's using the WQHL driver and has even went down to a driver before the 2020 update. The card worked fine on his Intel build, maybe it doesn't like the x570 chipset?
  13. When it crashes the GPU fans are stuck at 100%. Also the ram isn't OC at all. I thought of this too, he's probably on an old BIOS so I'm gonna get him to update it and see what happens. It's an EVGA 750W power supply, not sure it would be that but I guess it's possible.
  14. So my friend build himself a 3700x build. It's on a. Asus x570-pro with 16gb 3600mhz ram. He has his old rx 580 now and it keeps crashing in games and turning his display off, causing him to reset his PC. He has tried a fresh install of all drivers and windows and it still happens. He has tried different pcie cables to test as well. It lasts longer than it did before but still crashes in the end. It's an msi rx580 gaming x card. The temps only got to 66-67, while at 100% fan speed. All drivers are up to date and he is using 20.4.2 adrenaline release. Let me know if you have any ideas what it c
  15. That's what my guess would be, to install windows from USB it needs iso image I think
  16. Ryzen 3000 CPUs are not as cool as you think. My CPU is usually in the 40s idle on a custom loop (3800x). Have you checked the voltage your sending the CPU? The stock voltages are crazy high. Sometime 1.5v, if it's high try lowering to like 1.375 or 1.35v
  17. I've had this happen to me before. Safest bet would be to take it apart and check the spread on the paste. I know it's a pain in the ass but on my 2080ti my max temps I've seen are 56c on benchmarks and that was after my entire loop was at equilibrium. My card also idles at around 28-30c. My max temps I saw running cinnebench on a loop and furmark going as well.
  18. So got my new cable in, so far I haven't seen the issue anymore. No idea if it was the cable yet though.
  19. Was under the impression that chipset drivers were like gpu drivers and be kept up to date
  20. When it started happening at the beginning it was directly after I updated chipset drivers. It was like 2 updated ago. I have a 3800x on an x570
  21. What do you think could be wrong with my monitor? It's basically a brand new monitor. Only under a year old, it never did this before. I've kept everything up to date, bios chipset gpu. Everything. The cable I'm using is an old cable that came with an old monitor. I guess I should try an HDMI connection and see what happens.
  22. That's why I'm wondering if it's my cable or monitor. The only thing that hasn't changed is it's the same cable and monitor.
  23. That's the first thing I did when it happened again. But the same thing was happening on my old Radeon VII. I recently upgraded a couple days ago
×