Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

WesJD

Member
  • Content Count

    7
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About WesJD

  • Title
    Newbie

Contact Methods

  • Twitter
    http://twitter.com/WesJD

Profile Information

  • Gender
    Male
  • Location
    Maryland, USA
  • Interests
    Programming, biking, gaming.
  • Occupation
    Student

System

  • CPU
    Intel i5-4440k
  • Motherboard
    MSI Z97S SLI Krait Edition
  • RAM
    HyperX Savage 16GB(8GBx2)
  • GPU
    EVGA GeForce GTX 960 SCC
  • Case
    NZXT S340
  • Storage
    1TB WD Blue
  • PSU
    EVGA 500W
  • Display(s)
    2x Dell 27" Monitors
  • Cooling
    Cooler Master Hyper 212 EVO
  • Keyboard
    Razer Blackwidow Ultimate
  • Mouse
    Logitech MX Master
  • Sound
    Audio Technica ATH-M50x + Logitech G430s
  • Operating System
    Windows
  1. Yesterday I purchased a PowerColor RX 580 8GB from a person on facebook marketplace. When I installed the card, the fans spin but there is no display output. I brought the card to a friends house and tested it in his build and it worked flawlessly. I upgraded to an 8700K a couple of days ago and had either a dead motherboard or CPU, but I brought both back to the shop where I bought them and got them exchanged free of charge. Since the card was not working on the board that I believed failed me earlier (which has no buzzer or debug LEDs), I went back to the shop and paid the extra $20 for the MSI Z390-A Pro. Still, the card failed to display anything. I then proceeded to update the bios, change bios settings according to what others have tried online, but nothing has worked. The motherboard just doesn't recognize that the card is in the slot at all, so I can't try to flash a new bios to the card if that was the problem. Previously, I was using a GTX 960, so I've swapped that back in and its working fine. However, the far superior RX 580 sitting on the shelf in its box right now is saddening me. Does anybody have any ideas of what else I could try? People online have said possibly too much power draw (I have a EVGA 80+ WHITE 500W), but I haven't had any other components failing on me while I was running the card. Thanks to anyone!
  2. Blade 14, would be using it for work and gaming on the go.
  3. I have a 960 SSC, but a new card is never bad.
  4. I have never actually had an SSD in any of my systems and this would be a great start. Booting off of one is great for speeds in all but this would really be helpful in file transfer, lookup, etc, for me at least.
  5. The Kova (preferably black?). For day to day use I use an MX Master, but I have to switch for CS:GO, etc. My current wired mouse is getting a bit old and I think this would spice up my setup.
  6. Interesting how this packs a 960 in it. Impressive little computer, would be great for anyone, anywhere.
  7. Items look to have great quality and an industrial design. The mouse pad is what I'm most interested in, neat how they use that plastic (or other material) on the edges to help keep it down.
×