Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

NovaGear G2

Member
  • Content Count

    61
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About NovaGear G2

  • Title
    Member
  • Birthday 1995-10-17

Profile Information

  • Gender
    Male
  • Location
    New Jersey
  • Interests
    comic books, gaming, anime, manga, cartoons, animations, coding,

System

  • CPU
    Intel Core i5-4460 3.2GHz Quad-Core Processor
  • Motherboard
    Gigabyte GA-B85M-DS3H-A Micro ATX LGA1150 Motherboard
  • RAM
    G.Skill Ripjaws X Series 8GB (2 x 4GB) DDR3-1600 Memory
  • GPU
    EVGA GeForce GTX 960 4GB SuperSC ACX 2.0+ Video Card
  • Case
    Raidmax Viper GX ATX Mid Tower Case
  • Storage
    Seagate 1TB 3.5" 7200RPM Hybrid Internal Hard Drive
  • PSU
    EVGA 500W 80+ Certified ATX Power Supply
  • Display(s)
    AOC G2460PQU 24.0" 144Hz Monitor
  • Cooling
    Cooler Master Hyper 212 EVO 82.9 CFM Sleeve Bearing CPU Cooler
  • Keyboard
    Cooler Master CM Storm Devastator Gaming Bundle Wired Gaming Keyboard
  • Mouse
    Cooler Master CM Storm Devastator Gaming Bundle Optical Mouse
  • Operating System
    Windows 10
  • PCPartPicker URL

Recent Profile Visitors

871 profile views
  1. Not really. I have dissembled the laptop before but to a certain extent. It was just to replace one of the fans.
  2. Thanks, and yeah that's the confusing and frustrating part about it. That's why I thought it was fixable, that maybe it's some setting I need to change or update something. I'm actually responding to you right now with it because it's working perfectly fine now as if there was no issue to begin with but if I close the lid and open it up again, there's like a 8 out of 10 chance that it will go light black.
  3. I'm also not comfortable disassembling it since I don't have enough money to buy another one or parts to replace if broken. Also it's my only laptop, if it breaks I would have to bring my desktop into my dorm room, which makes it inconvenient for me since I don't completely trust my roommate with it, and it's gonna be inconvenient when working in class, plus I'm going to a hackathon next week.
  4. No, I doesn't trigger when the screen moves. I've picked up my laptop and walked around with it plenty of times and it does not go light black. Sometimes it works when I go into the BIOS and sometimes it does not.
  5. I mean I bought it a year ago and this problem appeared out of nowhere, and it seems fixable. Not like a cracked screen or anything. I also don't have enough money to send it in to Razer.
  6. So most of the time (which is really annoying) my laptop's screen turns to a light black screen every time I either close then open the lid, restart, shut down and boot up again, or try and boot into the boot menu. The keys still work and when I log in blind the second monitor displays just fine, and when I'm just interacting with the laptop display I can hear my actions taking affect, for example if I had a YouTube video open I can play the video, pause it, fast forward or rewind, mute the volume etc. If I was in a word document, I can type characters and drag the Microsoft Word window into the second display and see what I've typed. I originally thought it was booting up to the wrong display when turning on but it still occurs when my second monitor is disconnected, still occurs when I set the laptop screen as my primary display, which it already was, also when I set the second display as my primary display, the laptop screen is still light black, and when logging in the boot menu doesn't appear but the log in screen appears perfectly fine on the second display, it still happens when I only enable one of the two gpus in my laptop and when I enable both, and I tried uninstalling both display adapters and reinstalling them then updating their drivers, but that didn't work. Someone suggested DDU but I'm afraid that might not work either, but I'm going to try it later. Here are videos of what I'm talking about. https://drive.google.com/open?id=0B1Ux7FnDisigQUhCUTRBbWExT0U https://drive.google.com/open?id=0B1Ux7FnDisigc2dwWW1ESWtQSXM https://drive.google.com/open?id=0B1Ux7FnDisigd19TVkh4OHBPUU0 My laptop is a Razer Blade 14 (2014) Can someone help?
  7. Whenever I transfer a folder of files, or one large file the hard drive starts beeping and it disconnects and I get an error message that says it can't find the hard drive. However when I transfer large files or multiple files to the drive on my laptop, I get no problems, it works fine. What's going on here? How can I fix this?
  8. Good news is that it worked. I was able to change the drive to NTFS, bad news is that, on the Mac I can't move the files from the back up drive to the new NTFS drive, probably because it's NTFS now, the other bad news is that the drive has no problem being able to be detected on my laptop but won't be seen by my desktop. Up until now I've been trying to get the drive to be able to be seen on my laptop which it wasn't before,assuming that if it is able to be seen on my laptop it should be able to be seen by my desktop. Unfortunately that is not the case now.
  9. I know, I tried looking for NTFS but I couldn't find it in the dropdown menu for format. I'm hoping it'll be seen by my computer.
  10. I was gonna format it in exFAT or FAT32 in hopes that it will be detected by my computer, if it is then from there on my computer I'll format it to NTFS.
  11. I was actually planning on doing it through the disk utility app on the Mac.
  12. It was my dad's external hard drive, he used it for his Macbook all the time so he probably formatted it to work with his hard drive.
×