Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

knight_40k

Member
  • Content Count

    636
  • Joined

  • Last visited

Awards


This user doesn't have any awards

7 Followers

About knight_40k

  • Title
    Member

Profile Information

  • Gender
    Male
  • Location
    Canada
  • Interests
    Home Theater, Computers, Gaming, Modding, Home Renovation

System

  • CPU
    Intel Core i7 3770 @ 4.1 GHz - 1.14V
  • Motherboard
    MSI Z77-GD65
  • RAM
    16GB Kingston Hyper X DDR3 1600MHz (4x4GB)
  • GPU
    Asus Geforce GTX 1080 ROG STRIX A8G 8GB
  • Case
    Phanteks Eclipse P400S TG
  • Storage
    3x 128GB Crucial M4 SSD (Raid 0) // 3TB Seagate HDD
  • PSU
    Corsair AX850 w/ Custom Sleeved Cables
  • Display(s)
    Dell U2715H @ 2560x1440
  • Cooling
    Zalman CNPS9000MAX
  • Keyboard
    IBM Model M
  • Mouse
    Razer DeathAdder
  • Sound
    Asus Xonar DGX // 2.1 Logitech Z-3

Recent Profile Visitors

1,526 profile views
  1. Oh, I made it as GPT, should I be using MBR?
  2. I just created the iso and made the boot usb with roofus but it is failing to even launch. I'm thinking my ram or motherboard or nvme is bad, this should not be happening, period. I may take it to a shop and hope they can free diagnostic for me or atleast test/swap ram or use a random hdd to install, or something. Otherwise i have to return all of these items to amazon because I cannot verify which is the failing item.
  3. Yes it is. Could you walk me through how to make a win10 boot drive? It's been a while since I did this but I know i'll need rufus.
  4. No, I am still using the windows one. I pulled the m.2 from the system and am attempting an install on a hdd at this moment and seems to be working.
  5. I updated the BIOS and now I can get windows to launch the install, however now it crashing instantly when I try to install. Get the blue screen that says PC ran into problem and needs to restart when it attempts to load files. I think my M.2 is DOA.
  6. Update 2 I can get to the screen where I select windows 64 or 32 bit but then after selecting it continues to loop. Any ideas?
  7. Update- never mind... I figured it out. The boot option was set to USB, however, it wanted the UEFI USB to be selected in order to boot properly. Pretty confusing and stupid if you ask me.
  8. Can you link that as well as where I can download windows 10?
  9. I am using this windows 10 usb I changed the boot order to usb first and I even disabled all other boot options including the nvme, but I cant get it to launch
  10. HELP....title says all. My motherboard settings are default, using onboard graphics ryzen 2200g with asus prime b450 and 8gb ddr4 2666 (defaulted to 2133) and 256 m.2 nvme. I have an official windows 10 usb stick with license but the bios keeps looping saying insert boot-able device. I have tried the stick in several usb ports and I know it works because I used it to install on another system in the past. What is going on? Do I need bios update?
  11. I am wondering if anyone who owns this board can tell me if there is any reason not to update to the latest version 1820. I am currently on version 1201. I just like having my bios up to date.
  12. Thanks for the reply. I won't be doing any OC'ing as this is strictly for watching 1080p and 4K video. I was curious if the 2200g would be a better graphics option going forward and being I already own the GT 1030 I would have sold it.
  13. I am trying to do this as cheap as possible as my current HTPC is dying and I need to replace it asap. I want to buy everything from amazon so I have linked it below. 8GB DDR4 3200 (x1) https://www.amazon.ca/gp/product/B07M5RMLQW/ref=ox_sc_act_title_1?smid=A3DWYIK6Y9EEQB&psc=1 M.2 https://www.amazon.ca/gp/product/B0794WXF29/ref=ox_sc_act_title_2?smid=A26PVB3960EU85&psc=1 Ryzen 2200G https://www.amazon.ca/gp/product/B079D3DBNM/ref=ox_sc_act_title_3?smid=A3DWYIK6Y9EEQB&psc=1 Asus Prime B450M-A/CSM https://www.amazon.ca/gp/product/B07FKV5HWJ/ref=ox_sc_act_title_4?smid=A3DWYIK6Y9EEQB&psc=1 Will this be a decent system for 1080p/4k media playback on Kodi? I already have a case, hard drives and Seasonic 460W fanless psu. I am not sure about the m.2 as I see two different types of m.2, did i select the type with the proper end for my board? And is the onboard GPU of the 2200g more powerful than my GT 1030? Thanks in advance.
  14. Same thing happened to me once, I updated the BIOS on my motherboard and then it worked. I would recommend trying that.
  15. Give this a try. https://www.auralex.com/product/subdude-ii/
×