Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Tac127

Member
  • Content Count

    440
  • Joined

  • Last visited

Awards


1 Follower

About Tac127

  • Title
    Member

Profile Information

  • Gender
    Male
  • Location
    Ontario, Canada
  • Occupation
    School

System

  • CPU
    i5-4690 @3.50Ghz
  • Motherboard
    GIGABYTE GA-Z97X-GAMING 3
  • RAM
    Hyper X 8gb ddr3 @1600
  • GPU
    GIGABYTE GTX 950 WindForce 2X OC
  • Case
    Thermaltake Versa N23
  • Storage
    240GB Hyper X Fury SSD
  • PSU
    Cooler Master G750M
  • Keyboard
    k70 rgb
  • Mouse
    g502
  • Sound
    Hyper X cloud 2
  • Operating System
    windows 7 home premium 64bit

Recent Profile Visitors

1,047 profile views
  1. Then why did you reply to this question m8
  2. Is there not a better third party one?
  3. Whats the best one of those ultra cheap vr headsets for phones? Under 20 dollars tnx
  4. I cant figure out how to change the fps that it renders the final video into.
  5. Never mind I figured it out turns out a sd card in it was broken and was preventing it from booting.
  6. No specific price in mind just reasonably low and cant get a powerline adapter.
  7. Need a good cheap pci wireless care preferably black or red.
  8. I have tried that already and I dont know much a about it I know its a lenovo but thats a about it.
  9. My friends computer has suddenly started having a issue where every time he starts his computer it stays on the manufacturers logo screen for a abnormally long time then suddenly loses power with it and the back lit keyboard shutting off. Then it goes back to the logo and repeats. The computer and the power brick are both cool and we have tried booting with just battery, just cord and we have also tried taking out battery and unplugging then holding down the power button to no avail. Any help would be greatly appreciated thanks!
  10. How would it be the battery if it still didnt work just on ac.
  11. My friends computer has suddenly started having a issue where every time he starts his computer it stays on the manufacturers logo screen for a abnormally long time then suddenly loses power with it and the back lit keyboard shutting off. Then it goes back to the logo and repeats. The computer and the power brick are both cool and we have tried booting with just battery, just cord and we have also tried taking out battery and unplugging then holding down the power button to no avail. Any help would be greatly appreciated thanks!
  12. I would prefer something at night tho
×