Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

jackman4545

Member
  • Content Count

    6
  • Joined

  • Last visited

Awards


This user doesn't have any awards

2 Followers

About jackman4545

  • Title
    Newbie
  • Birthday April 9

Profile Information

  • Gender
    Male
  • Location
    Maryland, USA
  • Interests
    Computers, of Course

System

  • CPU
    Intel Core i5-4690K
  • Motherboard
    ASRock Z97 Extreme6
  • RAM
    Corsair DDR3 8GB (2x4GB)
  • GPU
    NVIDIA GeForce GTX 960 4GB DDR5
  • Case
    Mastercase 5 Pro
  • Storage
    256gb SSD, 1tb WD Blue Hard Drive
  • PSU
    Corsair CX750
  • Keyboard
    Razer BlackWidow Chroma
  • Mouse
    Razer Deathadder Chroma
  • Sound
    Razer Kraken Pro Chroma
  • Operating System
    Dual Booting Windows 10 and Ubuntu

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I have ran into issues like this in the past. We used to have comcast and downloads would take forever to download and probably never reach 100%. Try resetting your router. If that doesn't work than call your isp. I ultimately determined the cause of my issues was because the copper line running to our house was installed back in the late 1990s. We changed ISPs to FIOS and they had to install there own line into our house. Now we get the 50/50 download speed we pay for, sometimes more! Edit: Also, check to see if there is any packet loss on your internet connection. That could also be the cause of your downloads not finishing.
  2. i have a 2008 Compaq laptop that still runs well. It use to run windows vista but it was corrupted and now runs linux like a charm.
  3. vessel - jackyoung4545 https://www.vessel.com/videos/JYZEYDYx0 https://www.vessel.com/videos/LCoY5zfFf
×