Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

icestroge

Member
  • Content Count

    10
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About icestroge

  • Title
    Newbie
  1. The buttons on my current mouse don't work
  2. I would use this to finally be able to use the potential of my full custom loop water cooling.
  3. Sry not sure what is going on here really not exactly an expert *bump*
  4. Try enabling RAPID mode in Samsung magican
  5. I had a similar problem once before double check that the CMOS reset isn't set to the reset mode by accident, consult your manual to check.
  6. Run some diagnostics while you play, try to get record graphs of: FPS CPU load CPU temp GPU load GPU temp HDD activity RAM usage Resource monitor in windows can do some of this. Tab out after an FPS drop and check if anything bliped.
  7. When you can afford a new PSU get a reliable one maybe something linus has reviewed these are my recommendations http://www.dabs.com/products/corsair-430w-builder-series-cx-80--bronze-atx-power-supply-8BV9.html?utm_source=google&utm_medium=ppc%20product%20search&utm_campaign=Components%20and%20Storage%20-%20Cases,%20Cooling%20and%20Power%20-%20Power%20Supply%20Units or http://www.dabs.com/products/corsair-500w-builder-series-cx-80--bronze-atx-power-supply-8CDD.html?utm_source=google&utm_medium=ppc%20product%20search&utm_campaign=Components%20and%20Storage%20-%20Cases,%20Cooling%20and%20Power%20-%20Power%20Supply%20Units I had the same problem as you with my first PC with the same PSU and my PSU claimed to be 600W. It eventually burnt out, stopped working and filled my case with smoke.
  8. The fans (soo quiet) better than the one I have with a missing blade.
×