Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

LostInMyThoughts

Member
  • Content Count

    7
  • Joined

Awards


This user doesn't have any awards

About LostInMyThoughts

  • Title
    Newbie
  • Birthday 2002-06-24

Contact Methods

  • Discord
    LostInMyThoughts#0002
  • Steam
    https://steamcommunity.com/id/LostInMyThought/
  • Origin
    LostInMyThought
  • UPlay
    LostMyThoughts
  • Battle.net
    LostThoughts
  • PlayStation Network
    LostInMyThought
  • Xbox Live
    Onlyusedablade9
  • Twitch.tv
    LostInMyThoughts
  • Twitter
    @LostThoughts892

Profile Information

  • Gender
    Male
  • Location
    Colorado
  • Interests
    PC, Gaming, Anime and Video Making

System

  • CPU
    AMD Ryzen 7 2700x
  • Motherboard
    ASUS - ROG CROSSHAIR VII HERO
  • RAM
    CORSAIR - Vengeance RGB PRO 32GB
  • GPU
    EVGA RTX 2070 XC Ultra
  • Case
    Carbide SPEC-06 RGB Tempered Glass Case
  • Storage
    1TB Crucial P1 NVMe M.2 500GB Crucial P1 NVMe M.2 8TB WD My book 2tb WD Elements external HDD
  • PSU
    EVGA - 700W 80 Plus Bronze Power Supply
  • Display(s)
    Acer XG270HU omidpx 27" 2K 144hz and an ASUS Designo MX259H 24" 1080p 60hz
  • Keyboard
    Razer Huntsman Elite
  • Mouse
    Logitech g502 Lightspeed
  • Sound
    Razer Nari Wireless
  • Operating System
    Windows !0 64
  • Phone
    Samsung Galaxy Note 10+

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. My current display a a 2140x1440 144hz monitor
  2. I currently have a ryzen 7 2700x and a RTX 2070 super was considering upgrading to a RTX 3080 when they come back in stock and was wondering if im going to have to worry about any bottlenecking?
  3. It turns out it was just centurylink messing up the same day I reinstalled windows
  4. So I recently did a fresh install of windows and when after it was done the network worked fine but after updating windows I can only connect to certain sites like YouTube i tried opening discord it didn't work only way to get access to everything was enabling a VPN any clue on what could cause this or how to fix? I am connected to via ethernet.
  5. That was a dead end not a single response
  6. Recently I've been having issues with RAzer Synapse and no matter how much I search for any fixes I can't seem to find any. So I can run the app fine for a few hours but after awhile at some point the app stops working and freezes and I have to manually restart the app. I've tried multiple fixes like reinstalled the app i've also reinstalled the drives and even windows itself and it still happens. Anyone know of a fix?
×