Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

NathanH5

Member
  • Content Count

    7
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About NathanH5

  • Title
    Newbie
  1. Hi, Recently I built my PC which has a RTX 2080 ti and I was wondering what would be a good monitor to pair with it. Price isn't too big on an issue but would prefer to not to have to spend too much on it. Any advice is great;y appreciated, Thanks. Build list: https://pcpartpicker.com/list/HZm6HB
  2. Yah the vertical mount got in the way of the fan but I sorted that so it’s spinning now
  3. Hi, everyone thanks a lot I doubled a few things like the front panel and the 24pin connector and it powered on. i think I was just being a bit dumb. ive attached a photo of my building(with everything powered on).
  4. Hi, probably should’ve included this in my original post. https://uk.pcpartpicker.com/list/PrTLmg
  5. Hi, what I mean by nothing happened is that no fans or anything turned on I’ll try that now I’ll just need to find it.
  6. Hi, I am currently building a pc and when I tried first power on nothing happened ;(, so I did the usual thing and checked on the cables to make sure nothing was loose until I noticed that my motherboard( Asus rog strix x570-e) had a 12pin cpu connector instead of the standard 4 or 8 in most other builds I’ve seen, so I’m wondering if that is the reason my pc isn’t powering on. Any advice is greatly appreciated, thanks.
  7. Hi, you’ve probably have had a lot of these but I can’t seem to get my head around it. im using an Asus rog strix x570-e and I’m having trouble finding which places I plug the Power SW, Reset SW and the power led + & - since it’s rather unclear in the manual.
×