Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

LacerAcer

Member
  • Content Count

    4
  • Joined

  • Last visited

Awards


About LacerAcer

  • Title
    Newbie
  • Birthday 1994-01-17

Profile Information

  • Gender
    Male
  • Location
    Sweden
  • Occupation
    Locomotive mechanic

System

  • CPU
    Ryzen 9 3900X
  • Motherboard
    Gigabyte X570 Aouros Pro
  • RAM
    Corsair Vengeance LPX DDR4 3000MHz 32GB (16x2)
  • GPU
    Gigabyte Radeon RX 5700 XT GAMING OC 8G

    Gigabyte Radeon RX 580 8GB Aorus
  • Case
    Fractal Design Define R5
  • Storage
    HyperX Savage 480GB 2.5" SSD

    WD Desktop Black 4TB 3.5"
  • PSU
    EVGA GQ 1000W Hybrid Modular 80+ PSU
  • Display(s)
    AOC 24" LED FreeSynC G2460PF

    AOC 24" LED E2470SWH
  • Cooling
    Noctua NH-D15
  • Keyboard
    Some cheap PoS :P
  • Mouse
    Logitech G500
  • Sound
    Logitech G933 wireless headset
  • Operating System
    Windows 10 Pro

Recent Profile Visitors

40 profile views
  1. Can confirm, am cooking, my chili seedlings are happy I'm folding at least. XP
  2. I bought my W10 key from there a few years ago, still using it, if I recall correctly you don't have to enter the activation key at all if you are re-installing windows. They should have a library with your purchases in you account somewhere. I don't remember how long it took to get the key but I think it was near instant, for me at least. Good luck
  3. Have you tried resetting the BIOS? If that's not the problem, maybe windows update broke something?
×