Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Rob Ott jr.

Member
  • Content Count

    1
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About Rob Ott jr.

  • Title
    Newbie
  1. Last saturday my pc was moved from its normal location in the basement because of fears from flooding. During the night a chair that was also moved fell on top of the case from acouple feet above it. Chair was fairly light and padded. The top of the case had some minor damage, 2" crack in plastic, and small bend in top grill but the fan below it is completely fine.The pc wasnt plugged in and wasnt not knocked over. Power supply is bottom mounted. Microswitch for the power button clicks fine. Now when I try to boot the pc I get a quick flash (under a second) of the leds on the ssd, power button, and fan there nothing. This only happens on the first button press, after that I can press the power buttons as many times as i want and it will do nothing. If i unplug and then replug in the power supply cord it will do the quick led flash again once. Tried different power cables and same results. I cant see anything wrong. Ive reinstalled the ram sticks, checked all connectors, and tried different outlets. Specs are Ryzen R5 1600 Asrock AB350M Pro 4 2 x 8gb team group Vulcan ddr4 3000mhz Sapphire R9 280x 4gb Team group 120gb SSD 1TB Firecuda and 4tb seagate hdd Evga 500B 80plus bronze Linux mint 19.3 OS All parts have very little use with the ram and power supply being almost brand new. PC worked 100% before it was moved.
×