Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

AaronG 21

Member
  • Content Count

    55
  • Joined

  • Last visited

Everything posted by AaronG 21

  1. Ok so starting off I wanna say this is my first ever build. Build wise it turned out very good until my recent problem. After everything was in place, I first turn on the pc, and all fans are on, and running, GPU and CPU fans aswell. Even the keyboard is on, but when I look at the monitor, I see that there is no post, and the dram ez debug led is on. specs: the mobo (as the title says) it’s a msi b450m pro-m2 -ram 2666mhz ripjaws ddr4 -cpu it’s a ryzen 5 1600 -gpu msi Radeon rx480 4gb -psu it’s a 500w -128gb ssd -500gb hard drive things that I have tried: I have tried changing the ram sticks, to each other slot, trying each one, and nothing happens. So right now I’m currently thinking on changing ram sticks, to a ddr4 3200mhz, bc on my previous post, someone told me that my motherboard doesn’t support those ram sticks speed, (if someone can correct me if I’m wrong would be awesome, bc I tried finding it in the Manual and specs of the pc and I couldn’t find it.) so I ordered ram sticks that are ddr4 3200mhz that come in Sunday and hopefully that fix it all. If in any cases that doesn’t happen, can anyone tell me what other motherboard I could buy? That supports all of those specs, thank you so much, for your time, and hoping that you can help me
  2. Ok so starting off I wanna say this is my first ever build. Build wise it turned out very good until my recent problem. After everything was in place, I first turn on the pc, and all fans are on, and running, GPU and CPU fans aswell. Even the keyboard is on, but when I look at the monitor, I see that there is no post, and the dram ez debug led is on. specs: the mobo (as the title says) it’s a msi b450m pro-m2 -ram 2666mhz ripjaws ddr4 -cpu it’s a ryzen 5 1600 -gpu msi Radeon rx480 4gb -psu it’s a 500w -128gb ssd -500gb hard drive things that I have tried: I have tried changing the ram sticks, to each other slot, trying each one, and nothing happens. So right now I’m currently thinking on changing ram sticks, to a ddr4 3200mhz, bc on my previous post, someone told me that my motherboard doesn’t support those ram sticks speed, (if someone can correct me if I’m wrong would be awesome, bc I tried finding it in the Manual and specs of the pc and I couldn’t find it.) so I ordered ram sticks that are ddr4 3200mhz that come in Sunday and hopefully that fix it all. If in any cases that doesn’t happen, can anyone tell me what other motherboard I could buy? That supports all of those specs, thank you so much, for your time, and hoping that you can help me.
  3. So I Ordered those ram sticks, they are coming this Sunday. I hope that was the problem bc the video that I watched to make this pc, the only thing I was completely missing, was that the ram sticks instead of being 3200 MHz, I bought the ones that says 2666 MHz. So I really hope that was the problem. If in any cases (hoping this doesn’t happen) that the ram sticks doesn’t even work either, what other motherboard would you recommend me? That supports all my specs. I Really hope it isn’t necessary tho.
  4. My motherboard is a msi b450m pro m2 and my psu is a 500w, i was thinking on buying a 3200 hz ram, is there anything else I could do?
  5. So this is my first build, I put everything where it’s supposed to be but I get no signal from the monitor, other than in my motherboard the ez debug light for Dram is on. What should I do? I have a Ryzen 5 1600 (2x4) 8 GB of ddr4 ram 2666mhz msi rx Radeon 480 and 128 GB m.2 storage and a 500gb hard drive
×