Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Iovl123

Member
  • Content Count

    60
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About Iovl123

  • Title
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Tbh, mostly random stuff that probably had nothing to do with the actual fix to the problem, like setting higher priority in task manager. Regardless, ive tried them all, no matter how low the settings, how low the res is or how cold or Hot the card is, its artifacting like crazy..
  2. Hi guys, ive had my gigabyte 2070 super for several months now, and im pretty happy with it. Ive recently purchased rdr2 and atumbled upon a first for me. The game is artifacting like crazy, every couple mins the whole screen will artifact in white, green or blue orbs that grow in size till they fill the whole screen. Im only getting this problem in rdr2, and ive read online that the problem is not uncommon with the game. I was wondering if perhaps im getting bad power draw from the mobo? Its an old gigabyte b150m. My psu is gigabyte g750h from about 3 months ago. The card never exceeds 75c. Thanks!
  3. Ive tried low also, doesnt seem to change anything. Im pretty sure i used to get better performance with my 1070, cant remember clear enough though.. Beside, i would assume lowering the graphics would impact, at least to get stable 60?
  4. Hello guys, i have a really weird problem i hope you could help me solve.. For some reason im getting really bad performance in jedi fallen order, thats the only game im having problems with.. My specs: I7 6700 2070 super 2133 mhz 2x8 ram 3440x1440 res Im getting 55 fps, that fluctates between 45 to 60, with drops to 42. I would use freesync but i get insane brightness flickering in the game, to the point its not playable. Im getting same fps across all graphics settings, with epic dropping it about 3 fps more on average. Im getting around 80-100 fps on metro exodus with a mix of high-ultra, around 90 fps on witcher 3 on ultra, just this one game is unplayable.. Things ive tried: Reinstalling drivers. Overclocking gpu. Reinstalling game. Trying older drivers. Deleting the official game and downloading older versions from pirated sites. Reinstalling Windows. Im open to any suggestions.. Thanks in advance!
  5. You could try foxont the problem at hand for now. What is your psu, and how old is it? Does the card happen to have any visual damage?
  6. Check of the cooler is properly mounted, try to reapply thernal paste. If the voltage is too high try to undervolt alittle.
  7. As far as i know (using the exact same card) it doesnt have rgb. My windforce 1070 had rgb, i was looking for a way to turn on the rgb on my 2070 for like 2 hours before i googled it nad found out it has no rgb : /
  8. You should remove the top 2/3 brackets and insert the card at an angle, the brackets on the card shouldn't prevent it from going in. Use the top slot on the mobo.
  9. Hello guys, ever since i update to the latest driver, my gigabyte wf 2070s is running almost 10c hotter for no reason. The card used to run at around 65-67c when gaming (i know its pretty low) but now it runs at around 75 and can peak 78 sometimes. I didnt do a "clean installation" through the nvidia geforce experience, and i even checked the nvidia control panel to see if any settings had changed, and none did. Im using the adaptive power setting (as i always did) and i did not change anything aside from that... Any help would be appreciated!
  10. Did you install the latest driver for the card? Try that if you havent
  11. Thanks, i went and got the kit, im using the nzxt s340 and the installation was quite easy. I went from back and top outtake (stock) to back and top outtake + 2 front intake, and i did see some improvement.
  12. https://images.app.goo.gl/zurKhQngFbMaNRp49 I didnt buy it yet, but from googling the name thoae are the screws you get (best pic i found of the screws)
  13. Thanks, the 3 fan pack says it comes with 12 short screws and 12 long screws, figuerd the short ones are for mounting the fans onto the rad and the long ones are to mount both on the case. They should fot even without a rad, right?
  14. Hello, i was wondering if there would be any problem mounting fans meant for radiator as case fans? The fans are Thermaltake riing duo rgb 120 mm, i never installed case fans or rad fans, and i dont want to buy fans that wont be installed correctly. Thanks!
×