Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

TimUK

Member
  • Content Count

    3
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About TimUK

  • Title
    Newbie
  1. Finally finished the hardware side of things... (rgb included for performance)
  2. My god, thank you it lives, i can only assume their must have been something on my case shorting it? Everything is plugged in the same just outside of the case I spent 2 days troubleshooting all the steps above ^^ thank you for your help
  3. Hey all, Working on my second ever build and having alot of difficulty this time round with a new ryzen build. The issue: Motherboard lights up (white, blue and pink behind active cooling fan) when psu turned on but otherwise unresponsive. -side note- i felt i was avoiding cheaping out when i spent £170 on the mobo but the asus lacks all diagnosis features that might really help right now Build: Asus prime x570-p Ryzen 7 2700x Gigabyte gtx1080 g1 Corsair ddr4 3200mhz ram (4x8gb) 750w psu Troubleshooting steps taken: Tried switching ram positions Tried 1 stick, 2 sticks ( in a2+b2 and a1+b1 positions) and 4 sticks, Tried removing components till only mobo, psu and cpu attached, Tried alternative psu Checked 4pin and 8 pin and 24 pin power connections and re seated Reseated cpu verified no bent pins Attached a internal speaker, no beeps at all Checked pins for case power button and feel moderately confident it is wired corectly although motherboard really unclear Ive done everything i can find online to troubleshoot and was looking for any further assistance. Thanks in advance
×