Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

muhammadmustafa35

Member
  • Content Count

    7
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About muhammadmustafa35

  • Title
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I'm about to build a pc ,please suggest me a gaming motherboard.
  2. muhammadmustafa35

    Pairing my gpu with cpu!

    Is it okay to pair Sapphire rx 570 4gb with intel xeon e3 1225 v2?
  3. muhammadmustafa35

    can anyone fix my problem?

    I also calculated my power needs it says that you'll need 450 watts,so should l buy 450w or 550w?
  4. muhammadmustafa35

    can anyone fix my problem?

    I live in pakistan,myt budget is almost $40,i found these, 1)Thermaltake Litepower 450W ATX12V v2.3 Haswell Ready 2)Redragon RGPS GC-PS002 550W 80+ Bronze Gaming PC Power Supply 3)Corsair VS Series VS550 — 550 Watt Power Supply - CP-9020171-UK WHICH ONE SHOULD I BUY,OR TELL ME OF OTHER PSU THAT ARE BETTER.
  5. muhammadmustafa35

    can anyone fix my problem?

    AND i dont know what the problem is but as i remove 8 pin of the psu and use a sata to 8 pin the system works fine. in your opinion should i use sata to 8 pin or suggest me a psu. THANKS IN ADVANCE.
  6. muhammadmustafa35

    can anyone fix my problem?

    MY CONFIGURATIONS ARE: DELL PRECISION 1650 MID TOWER WITH XEON E3 1225 16 GB RAM 1TB HDD 128 GB SSD RX 570 4 GB
  7. muhammadmustafa35

    can anyone fix my problem?

    i recently upgraded to rx 570 4gb,with my stock power supply i.e.275 watts,using a sata to 8 pin connector. all was working fine until i saw a video which said you should have enough psu of the hardware may fail. then i bought a used psu which is Antec tp3 550watts. i brought that home and plugged into my motherboard ,it was working fine,then i plugged it into gpu and the computer didnot start. PLEASE HELP ME!!!!
×