Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

LordOfWinterfell

Member
  • Content Count

    173
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About LordOfWinterfell

  • Title
    Member

System

  • CPU
    INTEL I5 8400
  • Motherboard
    b360 pro-vdh from MSI
  • RAM
    G-SKILL ripjaws 2X8 ddr4 2400mhz
  • GPU
    SAPPHIRE RX580 8GB
  • Case
    RAIDMAX
  • Storage
    240GB SSDKINGSTONE & 1TB HDD from WD
  • PSU
    550 w
  • Display(s)
    acer gn246hl 144HZ
  • Cooling
    intel stock fan
  • Keyboard
    scorpion KM408
  • Mouse
    scorpion
  • Operating System
    WINDOWS 10 PRO

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Every time i buy a part for my PC i say: Finally this is the last part am gonna spend money on for quite some time. Just to see myself right now getting a ground loop>
  2. Its an issue with games only, not any other which makes it so weird for me to diagnose the problem
  3. If thats the case lets say, why should i buy an adapter when it was working fine 1 day ago
  4. nah not cross talk am sure
  5. After installing my new water cooler, am hearing like buzzing noise a noise i cant describe other than electrical, its not so loud but it hearable. I only hear it in games, not YouTube, discord, or Netflix.
  6. After installing my new water cooler, am hearing like buzzing noise a noise i cant describe other than electrical, its not so loud but it hearable. I only hear it in games, not YouTube, discord, or Netflix.
  7. The aio is working fine right? If yes, then who cares about RGB
  8. So the aio is working well, but rgb needs a converter, right?
  9. I tried plugging the strips in different ways ( its actually two ways, lol) and nothing changed wait a sec pls
  10. My cooler is from Gamemax 120mm. the strips or the connectors (whatever u call em) in the second picture came attacked to the fan and aio pump
  11. these connectors came with the cooler. i just plugged them together. I still dunno where is the mistake, why the rgb is not working. My motherboard: Asus rog strix b450-f
  12. I dunno dude, i just did that and this ->
×