Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Atemu

Member
  • Content Count

    10
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About Atemu

  • Title
    Newbie

Profile Information

  • Gender
    Male
  • Location
    Canada

System

  • CPU
    Intel i7 8700K

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Today my RMA ended by receiving a brand new RTX 2080 Ti from ASUS Thanks for your help!
  2. Fortunately my CPU, an i7 8700K, has an iGPU and my motherboard has a DisplayPort and HDMI ports.
  3. Just to keep you posted, this is what it looks like now
  4. Thank you for your help! I'm going to send the card back to ASUS and keep you posted.
  5. Idle I get about 35C degrees and at load around 72C degrees as you can see on the game screenshot. When I think about it, I don't think its the cause. Ah, well, no other choice than RMA it.
  6. Could the GPU overheating produce such artifacts?
  7. On the desktop: In a game:
  8. I think it is the later as I don't overclock my GPU. I'm going to start the RMA process then, thank you!
  9. It is an ASUS Strix RTX 2080 Ti OC edition 11GB
  10. Hey! Recently my RTX 2080 Ti started to act weird, I started to have artifacts on Windows and while playing video games as you can see on the following screenshots https://imgur.com/a/mPLD8IG. Is my GPU failing? Is it like the issue people had when the RTX launched? If that's the case I guess I should probably start the RMA process Thanks!
×