Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

pdr

Member
  • Content Count

    3
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About pdr

  • Title
    Newbie
  1. pdr

    League of Legends

    Hello everybody, basically I am here to ask you guys how do I play league ahah. I have been playing fps for years and I want to start to play LoL with my friends. They are not that advanced in the game but still I want to make a good impression. So I am here to ask you guys for some basic advice and tricks that can use to adapt to this style game which I have zero experience. Thank you all!
  2. Thank you all so much for your answers! @RadiatingLight @Sylvie @JDE @RedSector @STRMfrmXMN @Goildzy Wednesday I am going to try the desktop at a completely different location to see if it has something to do with the house's electric current. If this keeps happening, thursday I will go to the store and change my current PSU for another that does the job. After all this if the problem persists I can't think of anything less. I will keep you guys updated! Again, thank you so much for your input!
  3. Hello everybody! In october I bought and built a desktop. My friends, whom are enginners, helped with this process. The computer is a beast (I will post the components at the end) and as been struggling with a strange issue. Two weeks after I got the desktop, it started turning off and then back on by it self while I was gaming. I tried a lot of different fixes like checking temperatures, memory dumps, blue screens and stuff like that but everything seemed to be ok. Then I had an epiphany and tried to plug the power supply directly to my room's socket while previously was plugged to an extension. This seemed to fix the issue until two days ago. The curious thing about this is that it started happening right after nvidea drivers updates. Now I remove the drivers and reinstalled again its previous version (388.13). I haven't tried to see if this fixes the problem but still it is very strange that this happens because of my gpu and I would like to get a permanent fix. Hop you guys can help me fix this issue because it is really annoying to have a brand new pc that has such a problem. I appreciate, in advance, everybody's input that might help solve the problem. Here are the computer's specs:GPU: Asus Geforce GTX1060 Turbo 6GBCPU: Intel Core i5 - 8400Motherboard: Asus Prime Z370 - PRAM: HyperX Fury 16GB (2x 8GB) 2400MHz CL15SSD: Samsung 2.5 850 Evo 250GB TLC V-NANDHDD: WD 3.5 Blue 1TB 7200 RPM SATA IIIPSU: Cooler Master MasterWatt Lite 600
×