Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Amgzzz

Member
  • Content Count

    56
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About Amgzzz

  • Title
    Member
  • Birthday 2001-02-11

Contact Methods

  • Steam
    psandqs

Profile Information

  • Gender
    Male
  • Location
    New York
  • Interests
    Computer hardware, Gaming, Photoshop, German motorsports, Sound engineering.
  • Biography
    Im 15, I've been always wanting to build my own PC for a while now, I hated already built PC's with all my heart. I finally racked up about 700 dollars and spent it on PC parts, I've now got a gaming rig and look forward to upgrading it time to time and learning more about PC hardware.

System

  • CPU
    Haswell I5-4460 3.2ghz
  • Motherboard
    Asrock h97 anniversary
  • RAM
    2x4gb g skill ripjaws DDR3
  • GPU
    EVGA GTX 960 SSC 2gb
  • Case
    Rosewill Galaxy 01
  • Storage
    250GB Samsung 750 evo SSD
  • PSU
    None as of now

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. It was the power supply thanks for the help!
  2. It was the power supply I got a new one, let's all be nice here , thanks to both of you for at least trying to help I appreciate it.
  3. Yes this has been off, I didn't leave it on.
  4. I used thermal paste, and what plastic cover. The PSU is naked there's no covering on it, and the cooler if your talking about those stickers, I took them off.
  5. I meant to put z270-p the mobo is a 270 . I apologize
  6. That's the reason it powers off after 5 seconds?
  7. Specs: CPU: I5-7600k w/ Hyper evo212 MOBO: Asus Z270-P LGA1151 RAM: gskill aegis DDR4 300mhz 16gb CASE: Corsair 460x PSU: Corsair cx650m 650 watts HDD: western digital 7200rpm 1TB i put everything together correctly I'm pretty sure , except the hard drive, I didn't put the hard drive in yet. When I turn the computer on, CPU and case fan spins for 5 secs then turns off, and motherboard ram RGB lights are lit. The case had built in stand off's so I don't have to worry about those. I took the cooler off to see if I mis-seated anything but everything looked fine. All these parts are brand new. what could possibly be wrong
  8. windows 7 wont automatically install anything for me
  9. I installed windows again on my PC and downloaded Asus's latest drivers from their site, and when I try to install a steam game it just freezes every 30 seconds and then drops in connection. I have tried pretty much every ASUS driver. I dont know what to do now the problem still is not fixed. Cpu: I5-4460 mobo: H97 anniversary SSD: samsung 750 evo Wireless card: ASUS pce n15
  10. My speakers and pc is connected to the power surge and they work fine and I tried different ports and it doesn't work.
  11. My brand new asus monitor that I opened out the box , I plugged it in my surge protector first and when I tried turning it on I heard a click, and it quickly turned off. It doesn't turn on when connected to the power surge but is fine when connected to regular wall outlet. Why is this happening?
  12. Amgzzz

    Asus vs HP

    This hdmi switch you speak of, I can just plug it into the one hdmi port on the asus monitor and it will have 3 more hdmi ports? Something like that right?
  13. Amgzzz

    Asus vs HP

    I'll be sitting 2 feet away from the monitor , and if my tv didn't have a glare problem and it was a old LCD tv I'm sure this wouldn't either right? I really want the HP because of the two hdmi ports.
  14. Amgzzz

    Asus vs HP

    Any reason for your choice?
×