Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Arise_

Member
  • Content Count

    27
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About Arise_

  • Title
    Member
  • Birthday 1999-10-27

Contact Methods

  • Steam
    Arise

Profile Information

  • Gender
    Male
  • Location
    Ohio, USA

System

  • CPU
    i7-4790k
  • Motherboard
    Gigabyte GA-Z97X-SLI
  • RAM
    32Gb kingston hyperx ddr3 (1866)
  • GPU
    Gigabyte GTX 1080 Windforce
  • Case
    Corsair 780T black
  • Storage
    4TB seagate sshd, 2TB toshiba HDD, 1TB seagate HDD, 128GB SSD
  • PSU
    corsair 750M
  • Display(s)
    Acer widescreen(21:9), Asus (16:9)
  • Cooling
    custom watercooling loop with 360mm radiator (cpu only)
  • Keyboard
    Logitech G810
  • Mouse
    Steel Series Rival 300
  • Sound
    Soundblaster Omni, ATH-M50x
  • Operating System
    Win 10 Pro

Recent Profile Visitors

754 profile views
  1. This is the closest thing to a car that I could find, the link came straight out of the article that AshleyAshes recommended. https://en.wikipedia.org/wiki/Goldenrod_(car)
  2. try using ddu (display driver uninstaller) to uninstall your driver then reinstall it: https://www.guru3d.com/files-get/display-driver-uninstaller-download,17.html
  3. Is your display driver crashing, whats your display driver version number and what graphics card are you using?
  4. either roca from echofox or pasha from virtus.pro in csgo
  5. ive already deleted the oculus vr app so thats not it, ive heard that it is a recently deleted app that is showing up still but i dont know how to fix it
  6. I have been experiencing really bad battery problems on my galaxy S7 edge within the past week (after the most recent update) I have been uninstalling many apps and have finally solved the battery issue, well now i have a process showing under the battery area in settings called 10344 and it just has an android symbol next to it and its calculated battery drain is 47%. I found one other person having this problem but i haven't been able to fix it. please help me solve this! http://imgur.com/a/MoLjF
  7. i would say maybe forza horizon 3 if you have win 10, GTA V with mods can be very demanding.
  8. ok so i just downloaded evga precision and it only shows about 15% - 20% usage, how do i fix that
  9. oddly enough, i get that same fps on almost every map. dust II i get the highest, like almost 180 but still thats low
  10. great suggestion to reinstall the game, i dont know why i never though of that, ill try that as soon as i get home thank you. and ill look at evga precision.
  11. i recently uninstalled afterburner because i was getting display driver crashes and i found that the version of afterburner i had didnt agree with pascal cards at all, but i have gigabytes version and everything looks normal when i play games, usage is high-ish most of the time and the temps are just fine (~40c to ~70c under load)
  12. my old gpu was an asus gtx 980 strix, i used ddu and installed all the new, fresh drivers for my card and i uninstalled all of asus's software for the gpu
  13. Ive done that and it didnt help at all, thanks for the suggestion though!
×