Jump to content
Phishing Emails & YouTube Messages - Fake Giveaway Read more... ×
Search In
  • More options...
Find results that contain...
Find results in...
  • entries
    45
  • comments
    46
  • views
    5,586

The Adventures of Adding Thermal Pads to an EVGA GTX 1080 SC

Mira Yurizaki

896 views

tl;dr - things to know about installing the thermal pads

  • Your back plate may have extra padding where you need to install the back plate thermal pad. You'll have to remove these before applying the thermal pad.
  • The back plate has plastic covering parts where the thermal pad will be installed. This plastic is a pain in the rear to remove and leaves a obnoxiously hard to remove adhesive. If you want to feel like the thermal pad will actually do something and you want to remove it, be prepared to spend a lot of time scrubbing off this adhesive. I didn't have any Goo-Gone and alcohol makes the adhesive more gooey, but not necessarily easier to remove.
  • The LED power connector is a pain in the ass to remove. The reason is the connector is barbed so do not attempt to unplug the connector normally. Remove the fan header first, then flip the heat sink over to expose the LED power connector. Use an X-acto knife or something to shave off the barb.
  • EVGA sent VRAM pads for mine. You may get them too. Remember to clean the VRAM chips before applying the new pads.
  • After reassembly, spin the fans. One of the cables may have come loose from its guiding and may hit the fans.

 

A few days ago I got my thermal pad kit from EVGA for my GTX 1080 SC. Since today's the start of my weekend, I went ahead and installed it. While this shouldn't have taken as long as I took, I spent more time doing something other than installing the thermal pads which I'll go into detail later. Otherwise, you're probably looking at 30 minutes if you know exactly what to expect.

 

Also I guess this is a good time to show off my computer.

 

Step 1: Getting to the video card

1118161144a.jpg

 

Opening up the Silverstone FTZ01 leads into a nice compartmentalized motherboard area. I tried to keep the 3.5" bay area free of clutter. I feel the case fan and CPU fan do redundant work since they're pointed in the same direction, but hey, the CPU is always sitting at a nice cool temperature (then again, have a 65W processor helps)

 

So after unplugging things and taking out six screws holding the left side to the case and nudging it out of the PCIe slot.

 

1118161148.jpg

 

I don't like working with the video card if I can help it. Now you can see why.

 

1118161152.jpg

 

And there it is in all its glory!

 

Step 2: Disassembling the cooling system

 

[Insert picture of backplate here]

 

The backplate was easy to remove. Something to note though is there's some extra padding that you'll want to remove later. I forgot to take a picture of it, but here's one instead that I edited. The green is where I found extra padding that should be removed later (the rightmost one may not exist, I forget if it was there). the red ones are thermal padding, you should leave that alone.

 

backplate_pads.jpg

 

So after removing the backplate, I get this:

 

1118161156.jpg

 

And removing more screws, flipping the card over...

 

1118161203.jpg

 

I'd like to point out something. See the open connector closest to the camera? That's the fan header. It takes a bit of work but you can pry it up and off. However, the wires away from the camera? This is a huge freaking hassle to take off. That wire powers the LEDs. Why is it a hassle to take off? EVGA in their infinite wisdom made the connector barbed. I'm not angry at them for the whole thermal pad thing. I'm angry at them for making this connector a "set once and never remove" kind of deal. Yes I'm that mad!

 

Anyway the way I got it off was I took an X-acto knife and shaved off the barbs until I could get the damn thing off. Please EVGA do not do this again. Actually any AIB, if I catch you doing this I may have to go find your lead engineer and beat them over the head with the card and tell them to dissemble every card that comes in for an RMA that needs cooling disassembly

 

*Ahem*

 

Once we have the heat sink off, we have the card in its glor--- Is that a PCIe 8-pin header on the left there? Ya know EVGA, you could've just put the header there and saved us a bunch of trouble with your adapter thing... never mind.

 

1118161214.jpg

 

Step 3: Adding the thermal pads

 

At this point you should rub down the VRAM with alcohol since you need to add new thermal pads to them. I made the mistake (?) of not letting the card cool down completely so they were kind of icky. For cleaning the GPU itself, I used Arcticlean from Arctic Silver. It leaves a nice lemony scent.

 

1118161226.jpg

Here's the GPU all cleaned up and the VRAM chips with their new thermal pads. Now it's time to put the front plate back on and get the thermal pads for the chokes on.

 

1118161231.jpg

(also look how clean that heat sink is!) I did one more glory shot before adding some AS5. I added a glob of it which I thought would be best for a GPU.

 

The last step was to install the larger thermal pad on the back. I don't have pictures of this because here's what happened:

  • Remember the padding I mentioned? I pried those off because I figured the thermal pad would fill in that gap.
  • I realized then that a lot of that backplate has a plastic cover on it. I thought to myself "this thermal pad is obviously interfacing the PCB to the metal backplate and the plastic is just going to get in the way."
  • I started to remove the plastic, which left a bunch of adhesive on it. Apple be jelly of EVGA for their annoyingly hard to remove adhesive.
  • I spent the next half hour or so trying to scrape the adhesive off. I managed to get what I think most of it of, but urgh. I gave up, applied the thermal pad, and called it a day.

And this is why I didn't take pictures. I was too annoyed and butthurt about this adhesive.

 

After putting it back together and getting it in the case, I turned the computer on and heard this rattling noise from hell. That could only mean one thing! The fans somewhere are hitting something! So after taking out the video card I found what was going on: one of the fans was hitting that damn LED power connector:

1118161322a.jpg

It's a little hard to see, but you can see the left side the blade hitting the wire. There was also some kind of tape or something to keep the power and ground wires together and that's probably what was also being hit. In my effort to manhandle this LED power connector, I must've pulled it from some wire guiding in the shroud. So if you hear a rattling sound from hell, make sure your LED wires are tucked away.

 

Step 4: Testing the card out

 

After all was said and done, I put the computer back together, powered it up and...

 

holycrap_low_gpu_temps.png

 

Holy low temperatures Batman! 31C in about a 25-26C environment! So I let the AS5 bake for a few minutes then fired up 3DMark to run Sky Diver. The results came back... with 5000 fewer points. Well crap! But this was with my case laying flat, I set it up vertically and the score was back to normal. I guess laying the case horizontal chokes the video card enough.

 

Then for a reasonable stress test I fired up Heaven for half an hour while I let GPUz log the sensor data to check for anomalies.:

gpu_core_clock.pnggpu_load.pnggpu_mem_clock.pnggpu_tdp.png

gpu_perfcap.png

 

So far so good. It was maintaining boost clocks throughout, the memory clock was the same (so those thermal pads were working), and everything else was all green. The PerfCap reason was either due to voltage/power limits or underutilization, with a bit of the card hitting maximum voltage for flavor. So overall I call this a success.



0 Comments


Recommended Comments

There are no comments to display.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×