Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Can I damage my cpu/gpu etc if I run a game it can't handle?

I know it's probably a noob question.

 

But yeah. If I play a game like Ultimate Epic Battle Simulator for instance and I would spawn like a million units and start the game, can I damage my hardware? Because I want to test how many units I can get in while still getting an acceptable frame rate but I am a little scared in doing so.

Link to comment
Share on other sites

Link to post
Share on other sites

Short answer. No.

 

Slightly longer answer: At worst, you can get system instability and it will freeze or crash on you which always has a slight chance for data corruption. But physical damage, no, not at all.

Main Rig: cpu: Intel 6600k OC @ 4.5Ghz; gpu: Gigabyte Gaming OC RTX 2080 (OC'd); mb: Gigabyte GA-Z170X-UD3; ram: 16 GB (2x8GB) 3000 G.Skill Ripjaws V; psu: EVGA 650BQ; storage: 500GB Samsung 850 evo, 2TB WD Black; case: Cooler Master HAF 912; cooling: Cooler Master Hyper 212 Evo, Lots of fans, Air!; display: 4k Samsung 42" TV, Asus MX259H 1080p audio: Schiit Audio Magni Amp w/ Audio Technica M50x

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, superfantastic said:

But yeah. If I play a game like Ultimate Epic Battle Simulator for instance and I would spawn like a million units and start the game, can I damage my hardware?

No, computers aren't that dumb lol. The game might crash if your PC can't handle it but you can't damage your hardware. 

CPU: Intel Core i7-950 Motherboard: Gigabyte GA-X58A-UD3R CPU Cooler: NZXT HAVIK 140 RAM: Corsair Dominator DDR3-1600 (1x2GB), Crucial DDR3-1600 (2x4GB), Crucial Ballistix Sport DDR3-1600 (1x4GB) GPU: ASUS GeForce GTX 770 DirectCU II 2GB SSD: Samsung 860 EVO 2.5" 1TB HDDs: WD Green 3.5" 1TB, WD Blue 3.5" 1TB PSU: Corsair AX860i & CableMod ModFlex Cables Case: Fractal Design Meshify C TG (White) Fans: 2x Dynamic X2 GP-12 Monitors: LG 24GL600F, Samsung S24D390 Keyboard: Logitech G710+ Mouse: Logitech G502 Proteus Spectrum Mouse Pad: Steelseries QcK Audio: Bose SoundSport In-Ear Headphones

Link to comment
Share on other sites

Link to post
Share on other sites

Hey, better safe than sorry right? I don't mind asking a noob question if it can potentially save me some trouble! ?

 

Thanks for the answers.

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

The computer will usually crash back to Windows desktop...or be super laggy / stutter like a mofo.

The machine won't crash, burn, and self-destruct haha.

Intel Z390 Rig ( *NEW* Primary )

Intel X99 Rig (Officially Decommissioned, Dead CPU returned to Intel)

  • i7-8086K @ 5.1 GHz (still tweaking) -- i7-6800K
  • Gigabyte Z390 Aorus Master -- ASUS X99 Deluxe
  • Sapphire NITRO+ RX 5700 XT Special Edition -- 2x Sapphire NITRO R9-Fury in Crossfire
  • 32GB G.Skill TridentZ DDR4-3000 CL14 (16GB TridentZ RGB + 16GB Red/Black TridentZ)
  • SanDisk 480 GB SSD + 1TB Samsung 860 EVO + 1TB Intel 660p NVMe
  • EVGA SuperNOVA 850W P2 + Red/White CableMod Cables
  • Phanteks Enthoo Luxe Tempered Glass Edition
  • Ekwb Custom loop
  • Logitech G502 Proteus Spectrum + Corsair K70 (Red LED, anodized black, Cheery MX Browns)

AMD Ryzen Rig

  • AMD R7-5800X
  • Gigabyte B550 Aorus Pro AC
  • 32GB (16GB X 2) Crucial Ballistix RGB DDR4-3600
  • Gigabyte Vision RTX 3060 Ti OC
  • EKwb D-RGB 360mm AIO
  • Intel 660p NVMe 1TB + Crucial MX500 1TB + WD Black 1TB HDD
  • EVGA P2 850W + White CableMod cables
  • Lian-Li LanCool II Mesh - White

Intel Z97 Rig (Decomissioned)

  • Intel i5-4690K 4.8 GHz
  • ASUS ROG Maximus VII Hero Z97
  • Sapphire Vapor-X HD 7950 EVGA GTX 1070 SC Black Edition ACX 3.0
  • 20 GB (8GB X 2 + 4GB X 1) Corsair Vengeance DDR3 1600 MHz
  • Corsair A50 air cooler  NZXT X61
  • Crucial MX500 1TB SSD + SanDisk Ultra II 240GB SSD + WD Caviar Black 1TB HDD + Kingston V300 120GB SSD [non-gimped version]
  • Antec New TruePower 550W EVGA G2 650W + White CableMod cables
  • Cooler Master HAF 912 White NZXT S340 Elite w/ white LED stips

AMD 990FX Rig (Decommissioned)

  • FX-8350 @ 4.8 / 4.9 GHz (given up on the 5.0 / 5.1 GHz attempt)
  • ASUS ROG Crosshair V Formula 990FX
  • 12 GB (4 GB X 3) G.Skill RipJawsX DDR3 @ 1866 MHz
  • Sapphire Vapor-X HD 7970 + Sapphire Dual-X HD 7970 in Crossfire  Sapphire NITRO R9-Fury in Crossfire *NONE*
  • Thermaltake Frio w/ Cooler Master JetFlo's in push-pull
  • Samsung 850 EVO 500GB SSD + Kingston V300 120GB SSD + WD Caviar Black 1TB HDD
  • Corsair TX850 (ver.1)
  • Cooler Master HAF 932

 

<> Electrical Engineer , B.Eng <>

<> Electronics & Computer Engineering Technologist (Diploma + Advanced Diploma) <>

<> Electronics Engineering Technician for the Canadian Department of National Defence <>

Link to comment
Share on other sites

Link to post
Share on other sites

Yeah the only thing I could see going wrong is Windows crashing and causing data corruption. I have had that happen to me before with a lot of crashing issues but was able to repair it in Windows no problem. 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×