Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Kaby Lake 7700k running perfectly fine on Windows 7

MyLittleFella
 Share

After my yesterday's rage here on OS thread,

 

I decided trying to install Windows 7 again on my PC, and here the results:

 

1.jpg

 

Therefore, it's possible to use Windows 7 on Kaby Lake without any losses. The Cinebench score is kinda low because Turbo Boost is off, limitating the CPU @ 4.2GHZ.

NOTE: I played Dirt 4 and according to rivatuner, fps and cpu usage are exactly the same as windows 10.

CPU: Intel Core i7 7700k @ 4.2 GHz Stock; Mobo: Asus TUF Z270 MARK 2; RAM: Corsair Veangeance 32GB DDR4 (4x8) @ 2400MHz; GPU: GTX 1080 - GIGABYTE TURBO OC; Case: pcyes Polar Bear; Storage: Samsung 970 EVO Plus 500GB + Seagate Barracuda 2TB 7200RPM 64MB Cache; Cooling: Deepcool 240T; PSU: CX750M 2015

Link to comment
Share on other sites

Link to post
Share on other sites

Oh damn, can any moderator transfer this topic to the OS thread? I'm so used to come here at the "Off Topic" that I started the discussion at the wrong place... Sorry x.x

CPU: Intel Core i7 7700k @ 4.2 GHz Stock; Mobo: Asus TUF Z270 MARK 2; RAM: Corsair Veangeance 32GB DDR4 (4x8) @ 2400MHz; GPU: GTX 1080 - GIGABYTE TURBO OC; Case: pcyes Polar Bear; Storage: Samsung 970 EVO Plus 500GB + Seagate Barracuda 2TB 7200RPM 64MB Cache; Cooling: Deepcool 240T; PSU: CX750M 2015

Link to comment
Share on other sites

Link to post
Share on other sites

Downgrading from Windows 10 to 7 is akin to switching your undersized t shirt for an ugly Christmas sweater. Both sucks. 

Sudo make me a sandwich 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×