Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Low FPS for a 2080TI?

Slothinator
 Share

hello!

 

So I recently got a RTX 2080TI. When I play Battlefield 5 on the maximum graphic setting I get around 60-120 fps depeding on the map and where I am looking, is this low fps for this system or is to be expected? Also I played State of decay 2 yesterday and hit around 100+ fps constantly on the highest setting, but when I played today I only got around 60-80. here is a list of everything in my rig.

 

CPU: I7 8700

GPU: RTX 2080TI

Motherboard: Asus B360-F

PSU: EVGA Supernova G2 650W

RAM: 16Gg DDR4 2133Mhz

Storage: 223GB KINGSTON
               931GB Seagate
               465GB Samsung SSD 960 EVO 500GB

 

Link to comment
Share on other sites

Link to post
Share on other sites

On 1080p ultra you should be getting around 110 fps and on 4k 80fps on ultra settings. 

 

Are you playing on 4k or 1080p?

 

Also are your drivers updated (Im sure they are just curious)

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, HystericalII said:

On 1080p ultra you should be getting around 110 fps and on 4k 80fps on ultra settings. 

 

Are you playing on 4k or 1080p?

 

Also are your drivers updated (Im sure they are just curious)

Playing at 1440p. Ye latest drivers installed

Link to comment
Share on other sites

Link to post
Share on other sites

you never stated your display settings... 2133mhz memory handicaps even a CPU like the i7 8700 to some extend also...

Personal Desktop":

CPU: Intel Core i7 8700 @4.45ghz |~| Cooling: Cooler Master Hyper 212X |~| MOBO: Gigabyte Z370M D3H mATX|~| RAM: 16gb DDR4 3333mhzCL16 G.Skill Trident Z |~| GPU: nVidia Founders Edition GTX 1080 Ti |~| PSU: Corsair TX650M 80Plus Gold |~| Boot:  SSD WD Green M.2 2280 240GB |~| Storage: 1x3TB HDD 7200rpm Seagate Barracuda + SanDisk Ultra 3D 1TB |~| Case: Fractal Design Meshify C Mini |~| Display: Toshiba UL7A 4K/60hz |~| OS: Windows 10 Pro.

Luna, the temporary Desktop:

CPU: Intel Core i7 10700KF @ 5.0Ghz (5.1Ghz 4-core) |~| Cooling: bq! Dark Rock 4 Pro |~| MOBO: Gigabyte Z490 UD |~| RAM: 32G Kingston HyperX @ 2666Mhz CL13 |~| GPU: AMD Radeon RX 6800 (Reference) |~| PSU: Corsair HX1000 80+ Platinum |~| Windows Boot Drive: 2x 512GB (1TB total) Plextor SATA SSD (RAID0 volume) |~| Linux Boot Drive: 500GB Kingston A2000 |~| Storage: 4TB WD Black HDD |~| Case: Cooler Master Silencio S600 |~| Display 1 (leftmost): Eizo (unknown model) 1920x1080 IPS @ 60Hz|~| Display 2 (center): BenQ ZOWIE XL2540 1920x1080 TN @ 240Hz |~| Display 3 (rightmost): Wacom Cintiq Pro 24 3840x2160 IPS @ 60Hz 10-bit |~| OS: Windows 10 Pro (games / art) + Linux (distro: NixOS; programming and daily driver)
Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Slothinator said:

Playing at 1440p. Ye latest drivers installed

Are you using DX11 or DX12?

Personal Desktop":

CPU: Intel Core i7 8700 @4.45ghz |~| Cooling: Cooler Master Hyper 212X |~| MOBO: Gigabyte Z370M D3H mATX|~| RAM: 16gb DDR4 3333mhzCL16 G.Skill Trident Z |~| GPU: nVidia Founders Edition GTX 1080 Ti |~| PSU: Corsair TX650M 80Plus Gold |~| Boot:  SSD WD Green M.2 2280 240GB |~| Storage: 1x3TB HDD 7200rpm Seagate Barracuda + SanDisk Ultra 3D 1TB |~| Case: Fractal Design Meshify C Mini |~| Display: Toshiba UL7A 4K/60hz |~| OS: Windows 10 Pro.

Luna, the temporary Desktop:

CPU: Intel Core i7 10700KF @ 5.0Ghz (5.1Ghz 4-core) |~| Cooling: bq! Dark Rock 4 Pro |~| MOBO: Gigabyte Z490 UD |~| RAM: 32G Kingston HyperX @ 2666Mhz CL13 |~| GPU: AMD Radeon RX 6800 (Reference) |~| PSU: Corsair HX1000 80+ Platinum |~| Windows Boot Drive: 2x 512GB (1TB total) Plextor SATA SSD (RAID0 volume) |~| Linux Boot Drive: 500GB Kingston A2000 |~| Storage: 4TB WD Black HDD |~| Case: Cooler Master Silencio S600 |~| Display 1 (leftmost): Eizo (unknown model) 1920x1080 IPS @ 60Hz|~| Display 2 (center): BenQ ZOWIE XL2540 1920x1080 TN @ 240Hz |~| Display 3 (rightmost): Wacom Cintiq Pro 24 3840x2160 IPS @ 60Hz 10-bit |~| OS: Windows 10 Pro (games / art) + Linux (distro: NixOS; programming and daily driver)
Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Princess Cadence said:

Are you using DX11 or DX12?

Im using DX11 atm. So you also think I should get higher Mhz memory?

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Slothinator said:

Im using DX11 atm. So you also think I should get higher Mhz memory?

I don't know what's wrong, you're playing a semi-released game that has had one shit festival of development, any thing could be an issue.

 

Have in mind that the i7 8700 being a locked CPU with slow memory will not get the same single thread performance of the i7 8700K at 5ghz and 3200mhz memory, BF5 seems to be an extremely CPU intensive game, even more than the original BF1 therefore 144hz gaming might not be as simple as it looks achieving.

Personal Desktop":

CPU: Intel Core i7 8700 @4.45ghz |~| Cooling: Cooler Master Hyper 212X |~| MOBO: Gigabyte Z370M D3H mATX|~| RAM: 16gb DDR4 3333mhzCL16 G.Skill Trident Z |~| GPU: nVidia Founders Edition GTX 1080 Ti |~| PSU: Corsair TX650M 80Plus Gold |~| Boot:  SSD WD Green M.2 2280 240GB |~| Storage: 1x3TB HDD 7200rpm Seagate Barracuda + SanDisk Ultra 3D 1TB |~| Case: Fractal Design Meshify C Mini |~| Display: Toshiba UL7A 4K/60hz |~| OS: Windows 10 Pro.

Luna, the temporary Desktop:

CPU: Intel Core i7 10700KF @ 5.0Ghz (5.1Ghz 4-core) |~| Cooling: bq! Dark Rock 4 Pro |~| MOBO: Gigabyte Z490 UD |~| RAM: 32G Kingston HyperX @ 2666Mhz CL13 |~| GPU: AMD Radeon RX 6800 (Reference) |~| PSU: Corsair HX1000 80+ Platinum |~| Windows Boot Drive: 2x 512GB (1TB total) Plextor SATA SSD (RAID0 volume) |~| Linux Boot Drive: 500GB Kingston A2000 |~| Storage: 4TB WD Black HDD |~| Case: Cooler Master Silencio S600 |~| Display 1 (leftmost): Eizo (unknown model) 1920x1080 IPS @ 60Hz|~| Display 2 (center): BenQ ZOWIE XL2540 1920x1080 TN @ 240Hz |~| Display 3 (rightmost): Wacom Cintiq Pro 24 3840x2160 IPS @ 60Hz 10-bit |~| OS: Windows 10 Pro (games / art) + Linux (distro: NixOS; programming and daily driver)
Link to comment
Share on other sites

Link to post
Share on other sites

Oh I saw your performance DECREASED, did you auto-update through GeForce Experience the drivers? you know GeForce Experience does  TERRIBLE job getting rid of old drivers, you're advised to DDU in safe mode and reinstall it fresh new.

Personal Desktop":

CPU: Intel Core i7 8700 @4.45ghz |~| Cooling: Cooler Master Hyper 212X |~| MOBO: Gigabyte Z370M D3H mATX|~| RAM: 16gb DDR4 3333mhzCL16 G.Skill Trident Z |~| GPU: nVidia Founders Edition GTX 1080 Ti |~| PSU: Corsair TX650M 80Plus Gold |~| Boot:  SSD WD Green M.2 2280 240GB |~| Storage: 1x3TB HDD 7200rpm Seagate Barracuda + SanDisk Ultra 3D 1TB |~| Case: Fractal Design Meshify C Mini |~| Display: Toshiba UL7A 4K/60hz |~| OS: Windows 10 Pro.

Luna, the temporary Desktop:

CPU: Intel Core i7 10700KF @ 5.0Ghz (5.1Ghz 4-core) |~| Cooling: bq! Dark Rock 4 Pro |~| MOBO: Gigabyte Z490 UD |~| RAM: 32G Kingston HyperX @ 2666Mhz CL13 |~| GPU: AMD Radeon RX 6800 (Reference) |~| PSU: Corsair HX1000 80+ Platinum |~| Windows Boot Drive: 2x 512GB (1TB total) Plextor SATA SSD (RAID0 volume) |~| Linux Boot Drive: 500GB Kingston A2000 |~| Storage: 4TB WD Black HDD |~| Case: Cooler Master Silencio S600 |~| Display 1 (leftmost): Eizo (unknown model) 1920x1080 IPS @ 60Hz|~| Display 2 (center): BenQ ZOWIE XL2540 1920x1080 TN @ 240Hz |~| Display 3 (rightmost): Wacom Cintiq Pro 24 3840x2160 IPS @ 60Hz 10-bit |~| OS: Windows 10 Pro (games / art) + Linux (distro: NixOS; programming and daily driver)
Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, Princess Cadence said:

Oh I saw your performance DECREASED, did you auto-update through GeForce Experience the drivers? you know GeForce Experience does  TERRIBLE job getting rid of old drivers, you're advised to DDU in safe mode and reinstall it fresh new.

I've heard that newer drivers just decrease the performance but in this case I had the same driver yesterday when I had 100+ fps in State of decay 2 but today I only get around 60-100. It could have something to do with my overclocking of the GPU but it does have the same core and memory clock as yesterday, and the power limit/ temp limit is also the same

Link to comment
Share on other sites

Link to post
Share on other sites

I doubt its the overclock uninstall the drivers and reinstall them see if that helps 

Link to comment
Share on other sites

Link to post
Share on other sites

Enable pre render. Your frames will shoot up. I was getting 60 to 70fps with my 2080ti at 3440x1440 all ultra. I set pre render to on and I'm getting 110fps fairly consistently.

 

Theybe just enabled ray tracing too! So yay! 

Gaming PC: • AMD Ryzen 7 3900x • 16gb Corsair Vengeance RGB Pro 3200mhz • Founders Edition 2080ti • 2x Crucial 1tb nvme ssd • NZXT H1• Logitech G915TKL • Logitech G Pro • Asus ROG XG32VQ • SteelSeries Arctis Pro Wireless

Laptop: MacBook Pro M1 512gb

Link to comment
Share on other sites

Link to post
Share on other sites

On 11/13/2018 at 7:42 PM, Slothinator said:

When I play Battlefield 5 on the maximum graphic setting I get around 60-120 fps

Perfectly normal on Ultra Settings 1440p. Your cpu is probably even slightly bottlenecking the 2080ti, not because its slow, but because the 2080ti has such high performance overhead. 

Have you already installed the w10 october update? For some people that seems to cause performance issues.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×